RubyGems not installed for SDK

Hi, I'm using the Ruby plugin for IDEA, and I can't seem to debug or install gems through the IDE.

I'm using rbenv with ruby 1.9.3-p362 (on OS X) and when I go to File > Project Structure > Modules at the bottom of the modal window it says:

RubyGems not installed for SDK:
ruby-1.9.3-p362.
Please download and install rubygems

However RubyGems is installed on my system.

Also when I try to debug I get a message about ruby-debug-base19x not being installed (I assume because RubyGems is not installed)

Error running DebugTest:
Failed to Install Gems. Following gems were      not installed:
/Users/.../Library/Application      Support/IntelliJIdea12/ruby/rb/gems/ruby-debug-base19x-0.11.30.pre12.gem:      Cancelled
/Users/.../Library/Application      Support/IntelliJIdea12/ruby/rb/gems/ruby-debug-ide-0.4.17.gem: Cancelled     

thanks!

5 comments

What verson of IDEA/Ruby plugin are you using?
Also could you please try to remove the sdk and restart IDE.After that plugin should add it again.  Perhaps this will resolve the problem.

Regards, Oleg.

0

I'm using:

IntelliJ IDEA: 12.1.6
Ruby Plugin:         5.4.0.20130703

I tried removing the SDK and adding it again but I get the same errors.

As a test a installed RubyMine and everything works fine with it. I might have to switch, can I have a discount? :D



Attachment(s):
Screenshot 2013-11-20 10.01.13.png
Screenshot 2013-11-20 10.04.21.png
0

Could you please try Idea13 RC with the latest Ruby plugin

Thanks in advance, Oleg.

0

That worked, 13 picked up my rbenv ruby right away.

I did manage to get 12 working if I set the rbenv gems bind directory manually.

thanks,
Alastair

0

I'm happy to hear that you have been able to solve the problem and that we have fixed it in a new version of ruby plugin.

Regards, Oleg.

0

Please sign in to leave a comment.