5.4.3.2.1 appears to not support newer hash syntax with sdk 2.0.0

When I am using RMI 2.0.0 and using a hash syntax like:

{ foo: 'bar', baz: 'bat'}

Rubymine's syntax check flags all lines using this syntax as being in error.

How can I fix this?

2 comments

Please check if ruby sdk is set for the project and it has 1.9/2.0 language level.

Regards, Oleg.

0

Ach!  Sorry to have raised this issue.  I had actually introduced a syntax error across a number of lines of code. RubyMine actually does support the new hash syntax.  It was flagging a syntax error that I was too blind to see. (There are none so blind as those who will not see!)

Mea culpa.

0

Please sign in to leave a comment.