Rubinius support

I'm working with the Momiji beta EAP, and trying to configure and use rubinius, but when I select the rbx 2.1.1 SDK, Rubymine can't find rubygems.  From there, it can't find bundler, and so many things are broken.

This blog post seems to sum up my issues, and a workaround:  http://spiridonov.pro/2012/09/18/rubinius-and-rubymine/

Is there any other solution, or something that is missing?  Is this something that can be fixed?

1 comment

Hi,

thank you for analyzing and findng workaround for the problems RM has with a new rubinius.
The new version breaks some assumption we've made in the past and it may take a lot of work to fix this :(
But anyway I'd suggest to file issues to our tracker (http://youtrack.jetbrains.com/issues/RUBY).  
I will no promise to fix them ASAP (it looks like rubinius is not a mainstraem :() but users will be able to vote for them and help us prioritize them correctly.

Regards, Oleg.

P.S. we already have one about debugging support http://youtrack.jetbrains.com/issue/RUBY-14118

0

Please sign in to leave a comment.