The ruby mine ide does not show variables when debugging remotely

On the server side. (ubuntu 12.04, ruby 1.9.3-p448)
rdebug --host server-ip --port 1234 -- hello.rb
Fast Debugger (ruby-debug-ide 0.4.18, ruby-debug-base19x 0.11) listens on server-ip:1234

On the client side (ubuntu 12.04, ruby 1.9.3-p448)
Remote host: server-ip
Remote folder: .
Local folder: immediate parent folder for hello.rb
Local port: 26192

The RubyMine connects to the debugger but it does not display anything in the debugger window.  I can step over to next breakpoint and complete the debug but no stack.  I have attached screenshot for reference.

BTW... If I run the server-side command locally then I am able to see the stack and variables.

Any help will be really appreciated.

-Kuppa



Attachment(s):
rubymine-remote-debug-nostack.png
5 comments
Comment actions Permalink

My gem list on the server

archive-tar-minitar (0.5.2)
bigdecimal (1.1.0)
columnize (0.3.6)
debugger (1.6.2)
debugger-linecache (1.2.0)
debugger-ruby_core_source (1.2.3)
io-console (0.3)
json (1.5.5)
linecache19 (0.5.12)
minitest (2.5.1)
rake (0.9.2.2)
rbx-require-relative (0.0.9)
rdoc (3.9.5)
ruby-debug-base19 (0.11.25)
ruby-debug-base19x (0.11.30.pre15)
ruby-debug-ide (0.4.18)
ruby_core_source (0.1.5)

0
Comment actions Permalink

Do you have Gemfile? If yes what is in it?
Also I'd suggest to run debugger in verbose mode (Settings|Debugger|Ruby) and provide the output it produces.

Regards, Oleg.

0
Comment actions Permalink

I enabled the verbose debugger option in "Settings|Debugger|Ruby" but I did not get any output in the client side (IDE) and I even looked at the ~/.RubyMine50/System/logs/idea.log but not output either.  

I enabled debug on the server side.  I have attached the output.  I create two scenario, 1. both server and client runs on the same machine 2. server and client on the different machine.   Please see the attached file.

I can see lot more information (including variable information) if I run both on the same machine but it does not available if server and client are different machine.



Attachment(s):
remote-debug-server-side-two-different-machine.log.zip
remote-debug-server-side-two-same-machine.log.zip
0
Comment actions Permalink

I forgot to mention that there is no Gemfile.  I am keeping it simple for now that the script is just 4 lines.

hello.rb
first_name = "S"
last_name ="K"
full_name = "#{first_name} #{last_name}"
puts "Hello #{full_name}"

0
Comment actions Permalink

Hi,

It looks like a bug for me, could you please file it in our tracker (http://youtrack.jetbrains.com/issues/RUBY)

Thanks in advance, Oleg.

0

Please sign in to leave a comment.