Spork + Minitest + Rails 4 + Ruby 2.0

hi, all..

i just started a new project using all the latest stuff..

i am having just a few problems..

when i run spork in the command line, i get:

Using MiniTest
Preloading Rails environment
Loading Spork.prefork block...
Spork is ready and listening on 8988!



but when i try to run in rubymine, i get:

/Users/sergio/.rvm/rubies/ruby-2.0.0-p247/bin/ruby -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) -Itest /Users/sergio/.rvm/gems/ruby-2.0.0-p247/bin/spork testunit
Couldn't find a supported test framework that begins with 'testunit'

Supported test frameworks:
( ) Cucumber
(*) MiniTest
( ) RSpec

Legend: ( ) - not detected in project   (*) - detected

Process finished with exit code 1



is there something i need to do to force spork run minitest rather than bootsrap?


my next issue is:

when i run my tests, i get the following error:

unable to attach test reporter to test framework or test framewhork quit unexpectedly.

any ideas?

thanks!

Attachment(s):
Gemfile.lock_-_menards_configurator_-____Sites_menards_configurator_.png
1 comment

Hi,

as for using minitest with RM see http://www.jetbrains.com/ruby/webhelp/minitest.html
To use minitest+RM+spork: we require spork-testunit to make this work.

Hope this helps, Oleg.

0

Please sign in to leave a comment.