Max OS X - Strange IDE (edition and navigation) behaviour.

Today my RubyMine started to behave strangely - most of the shortcuts stopped working (however they are visible in the keymap) and some other keys changed behaviour.

For now I have found following issues:

  • Arrow keys scroll instead of moving cursor
  • Shortcuts doesn't work anymore (for example ^F)
  • Backspace doesn't work

However I can move the cursor around using mouse and write changes to the source files.

Have I entered some strange mode?



the behavior you describe is similar to one when CMD button is pressed so I'd check if it works correctly.
If the strange behavior is RM specific and pressing CMD doesn't help then please check if you have IdeaVIM or some other plugin which may affect the keyboard behavior.

Hope this helps, Oleg.


I have tried pressing CMD button (with and without restarting the IDE) but the problem persists.
My RubyMine copy is fresh, no additional plugins installed.

Thanks for the fast answer and reference to Vim plugin (I will get that one when we solve the issue).

Any other ideas?


Please check you keymap in RM (Settings|Keymap) perhaps it was mistakenly hanged to somthing strange)
Do you have any specific settings for keyboard in Mac?  Also what version jdk are you using?



I use the default keymap: Mac OS X 10.5+
RubyMine version is the newest one.

Java versions (Oracle)
javac 1.7.0_25

java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)


Could you please try to use jdk 1.6 instead.  Also what version of MacOs are you using?

Regards, Oleg.


Mac OS X version is 10.8.4.

I have followed the instructions for uninstalling and restoring Apple's Java (, restarted the IDE and it is working again.
However the Java version is still 1.7 (opened new terminal for check) - I will check if everything still works after reboot and post if I have any issues.

Thanks for help.

PS: can you fix the title to "Mac OS" (it is "MaX OS" now).


I'm glad to hear that the problem has been resolved.
As for the title: it looks like I can only fix the title for my reply, but I do not think it is a big problem (everyone will understand it correctly anyway ;)



Please sign in to leave a comment.