Can't get Rails Debugging to work on RM 5.4.3.2.1 evaluation, OSX 10.7.5

Hi All,

I'm currently evaluating RM for a small team of developers and I'm struggling with the debugger. Here's my current config:

1. RubyMine Evaluation 5.4, running on OSX 10.7.5
2. rbenv running Ruby 1.9.3p194, Rails Rails 3.2.7
3. Project is Rails, was created previous to RubyMine evaluation (I chose "open folder")
4. gem list | grep debug ->
debugger-ruby_core_source (1.2.3)
ruby-debug-base19x (0.11.30.pre14)
ruby-debug-ide (0.4.18, 0.4.17.beta17)
5. The actual error (when trying to run the project from the debug panel):
/Users/mauriciochavarriaga/.rbenv/versions/1.9.3-p194/bin/ruby -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /Users/mauriciochavarriaga/Projects/SSSS/development/active_classroom/script/rails server -b 0.0.0.0 -p 3000 -e development
/Users/mauriciochavarriaga/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.18/lib/ruby-debug-ide.rb:6:in `require': cannot load such file -- ruby-debug-base (LoadError)
 from /Users/mauriciochavarriaga/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.18/lib/ruby-debug-ide.rb:6:in `<top (required)>'
 from /Users/mauriciochavarriaga/.gem/ruby/1.9.1/gems/bundler-1.4.0.pre.2/lib/bundler/runtime.rb:76:in `require'
 from /Users/mauriciochavarriaga/.gem/ruby/1.9.1/gems/bundler-1.4.0.pre.2/lib/bundler/runtime.rb:76:in `block (2 levels) in require'
 from /Users/mauriciochavarriaga/.gem/ruby/1.9.1/gems/bundler-1.4.0.pre.2/lib/bundler/runtime.rb:72:in `each'
 from /Users/mauriciochavarriaga/.gem/ruby/1.9.1/gems/bundler-1.4.0.pre.2/lib/bundler/runtime.rb:72:in `block in require'
 from /Users/mauriciochavarriaga/.gem/ruby/1.9.1/gems/bundler-1.4.0.pre.2/lib/bundler/runtime.rb:61:in `each'
 from /Users/mauriciochavarriaga/.gem/ruby/1.9.1/gems/bundler-1.4.0.pre.2/lib/bundler/runtime.rb:61:in `require'
 from /Users/mauriciochavarriaga/.gem/ruby/1.9.1/gems/bundler-1.4.0.pre.2/lib/bundler.rb:130:in `require'
 from /Users/mauriciochavarriaga/Projects/SSSS/development/active_classroom/config/application.rb:7:in `<top (required)>'
 from /Users/mauriciochavarriaga/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.7/lib/rails/commands.rb:53:in `require'
 from /Users/mauriciochavarriaga/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.7/lib/rails/commands.rb:53:in `block in <top (required)>'
 from /Users/mauriciochavarriaga/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.7/lib/rails/commands.rb:50:in `tap'
 from /Users/mauriciochavarriaga/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.7/lib/rails/commands.rb:50:in `<top (required)>'
 from /Users/mauriciochavarriaga/Projects/SSSS/development/active_classroom/script/rails:6:in `require'
 from /Users/mauriciochavarriaga/Projects/SSSS/development/active_classroom/script/rails:6:in `<top (required)>'
 from -e:1:in `load'
 from -e:1:in `<main>'

Process finished with exit code 1

Any ideas? Thanks in advance.

1 comment

Hi,

I might be wrong but I'd double check that your Gemfile doesn't contain debugger gem.
If it is please comment it our and check if this fix the problem (it is a know limitation that ruby-debug-ide is not compatible with debugger :()

Please let us know if this helps or not.

Regards,, Oleg.

0

Please sign in to leave a comment.