How do I exclude a specific gem from being indexed?

Mac OS X 10.8.4

I am running the latest build of Momiji (130-1770), but am also seeing this behavior in 5.4 and 5.4.3.  

Rubymine gets stuck on indexing this file:

~/.rvm/gems/ruby-1.9.2-p290@redflag/gems/nokogiri-1.6.0/ext/nokogiri/tmp/i686-apple-darwin11/ports/libxslt/1.1.26/libxslt-1.1.26/doc/apibuild.py

Then my CPU spikes to 100%+ usage, and in almost every case, Rubymine will become unresponsive and have to be forced quit. On rare occasions, the indexing is skipped (or something) and CPU usage is normal.

Does anyone know how I can ask to have the nokogiri gem excluded from indexing (or even the entire set of gems - I don't really care at this point)?

I have logged a bug with JetBrains as well, fyi.

Thanks,
Wes

1 comment

Perhaps you could try to add the gem to ignore list (but I doubt this will help) and (unfortunately) there is no other option :(

At the same time it would be interesting to find out if the problem is local for you or other people experience the same
problem too because I was unable to reproduce the problem locally (but I'm using Linux).

Oleg.

0

Please sign in to leave a comment.