No Rails found in SDK (in Rails4)

Hello everyone.

I tried Rails4.0.0rc2 in RubyMine 5.4.
But, RubyMine shows me the error 'No Rails found in SDK'.

I installed Rails and other Gems into the vendor/bundle directory in Project Folder.
I guess that RubyMine could not detect rails in the vendor/bundle directory.
( I don't like to install rails in ruby environment directly. )

How do I solve this problem?



Attachment(s):
RubyGemsEnvironment.txt.zip
6 comments

Incidentally, I'm using Rails3.2.x in RubyMine successfully.
( Of course, rails is installed in the vendor/bundle directory. )

0

Hi,

it looks like a bug for me, but it is fixed in current code and the fix will be available in next RM's version.

Regards, Oleg.

0

Thank you for your response.

I'm looking forward to getting the next RM's version.
BTW, When the next version will be released?

Regards, Yuki.

0

We have one stopper with RubyMotion support which require fix in RubyMotion itself.  As soon as it will be available and we re-test RM we will release it.

Oleg.

0

I see.
I'm sitting back and waiting for the release:)

Yuki.

0

I confirmed that the problem was fixed in the latest version.

Thank you!

Yuki.

0

Please sign in to leave a comment.