Undo global "Darcula" colors

Hi,

I tried to use the "darcula" theme in RM 5, and clicked "Yes" when it asked me if I want to
change the colors of the global IDE colors as well.

Now I don't find an option to "Undo" these IDE changes. I can switch the theme for the
editor window but can't find a way to restore the default light IDE colors (file menu, etc).

Can somebody help me here? :)

6 comments
Comment actions Permalink

It's the material theme plugin that's overriding everything. I kept trying to switch to something other than Darcula and it wouldn't let me. Remove the material theme and you'll be able to switch themes.

3
Comment actions Permalink

Go to File|Settings|Appearance and change "Theme" to something else.

Hope this helps, Oleg.

0
Comment actions Permalink

I'm using RubyMine 5.4 on OSX, and I'm running into the same problem. Darcula won't go away. It's like a bad horror movie.

Among other things:

- There's no "File", "Settings" menu option.
- Under "File", "Default Settings", there's no "Appearances" option.
- Under "RubyMine", "Preferences", "Editor", "Colors and Fonts", I can select "Darcula", "Default", "GitHub", etc. But I tried out "Darcula" just once, and now I can't get rid of it. Choosing any of the other options changes the colors of the editor windows, but none of the other windows.

Any advice? (Seeing as how I don't particularly care for the Darcula theme - it makes it too difficult to read the various tab titles, among other things.)

0
Comment actions Permalink

Hi Ken,

I'm running Rubymine 5.4. on OSX as well. You can reset the Darcula IDE theme as advised
by Oleg - just the File / Settings stuff seems to be different in OSX.

When in Rubymine, click on "Rubymine" in the menubar, then choose "Preferences".
Under the subsection "IDE Settings" you find "Appearance" and on the right
the "Theme" (see screenshot).

BTW: I've kept the Darcula theme. After a couple of days you get used to it and don't want to switch
back. ;-)

Best
Christian



Attachment(s):
screenshot_2013-04-29_17.32.28.png
0
Comment actions Permalink

Got it, thanks. Having the settings in two different places is certainly an odd UX choice, but perhaps there were other constraints.

0
Comment actions Permalink

Thank you W0299294. That was killing me.

0

Please sign in to leave a comment.