ruby 2.0 (macports) supported by RubyMine 5+ ?

Selecting new ruby2.0 binary through 'Add SDK...' action is improperly detecting that rubygems are not installed.

Screen Shot 2013-04-03 at 1.10.00 PM.png
Screen Shot 2013-04-03 at 1.13.58 PM.png

(on latest EAP build)

> ruby2.0 -v
   ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-darwin12]



> gem2.0 -v
   2.0.0

> java -version
   java version "1.7.0_17"
   Java(TM) SE Runtime Environment (build 1.7.0_17-b02)
   Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)

1 comment

Answer to self -

Use macport 'ruby_select' tool to select wanted/active ruby version.
Not sure when this dependency was added.

Solution:

$> sudo /opt/local/bin/port select ruby ruby20
  Selecting 'ruby20' for 'ruby' succeeded. 'ruby20' is now active.

$> sudo /opt/local/bin/port select --list ruby
  Available versions for ruby:
  none
  ruby18
  ruby19
  ruby20 (active)

0

Please sign in to leave a comment.