ugly render fonts inside linux

Hi...I've used rubymine in windows and It look superb..but I had install it in mandriva and the font look really ugly, I know linux render font is different but the mandriva fonts look great (I change the render for it and look even better) I know the java ap fonts are differents too..but I've netbeans, other ide developed using java and the font look great, I love Rubymine but I can't work with it if it has this font because I'm tied to linux now ...please help!

I try change the render font inside mandriva
change the fonts too

change the fonts and size inside rm
but all these don't fix the poor render
Help!

thanks

7 comments
Comment actions Permalink

Hi..thanks for the reply but I've a problem, in rubymine don't appears Use antialiased font..the other problem is I use fedora and the solution seems work only for debian

0
Comment actions Permalink

Hi Angel,

Hi..thanks for the reply but I've a problem, in rubymine don't appears Use antialiased font..the other problem is I use fedora and the solution seems work only for debian

Do you mean that you check option "Use antialiased font" and it doesn't work for you? Note that this option works only inside editor.
Have you tried configure fonts using File | Settings | Appearance | Override default fonts by (not recommended) ?

Regards,
Oleg

0
Comment actions Permalink

Hi..thanks for the reply..when I check Use antialiased font it don't work, even I restart RM and not happen anything....I change the font too and it look even poor....I think the problem is java but I only found solutions for debian and not for fedora or mandriva..thanks

0
Comment actions Permalink

Hello Angel,

Hi..thanks for the reply..when I check Use antialiased font it don't work, even I restart RM and not happen anything....I change the font too and it look even poor....I think the problem is java but I only found solutions for debian and not for fedora or mandriva..thanks

Hmm, seems like it's a Java bug itself. I don't have much experience using Mandriva...
Could you please drop a line here if you find the correct solution. It seems to be helpful for others.

Best regards,
Oleg

0
Comment actions Permalink

I found this on a Fedora forum, which solved the problem for me:

_JAVA_OPTIONS must be set with some options:

export _JAVA_OPTIONS="-Dswing.aatext=true  -Dawt.useSystemAAFontSettings=on  -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel"


So put this in your .profile, or in a script that runs RubyMine, or on the mine command line, etc.

- Keith
0
Comment actions Permalink

Hi! I had a similar trouble as you, and all linux JetBrains products users. And I found a solution which works for me and another users. Here is the link to article:http://openite.com/en/Development/2013/02/13/fonts-issues-fix-for-jetbrains-products-on-linux.html

Hope this will help you!

0

Please sign in to leave a comment.