Setting up for Rails 4 development

I am using RubyMine 4.5.4.

I am currently using ruby-1.9.3-p125 with rails 3.2.6

I installed the Rails 4 gem as follows:

rvm gemset create rails-4.0
rvm 1.9.3@rails-4.0
git clone https://github.com/rails/rails.git
gem install thor


When I start a project, and select rails application, I get another dialog to selet the Ruby interpreter (dropdown list:
ruby-1.9.3-p125
ruby-1.9.3-p125-[global]
ruby-1.9.3-p125-[mysql-2]
ruby-1.9.3-p125-[rails-4.0]

If I select the last one (rails 4), everything is gretyed out, including the OK button.

How do I get my IDE to work with Rails 4 and did I install Rails 4 correctly?

3 comments
Comment actions Permalink

You have not installed Rails gem, but rather cloned Rails 4 repository. Generating application from Rails repo is not supported.
If you want to create Rails 4 application you can follow setting up part of this Railscast and simply open generated app with File | Open Directory.

0
Comment actions Permalink

When will RubyMine support Rails 4 natively?


0
Comment actions Permalink

In order to generate Rails app from New Project dialog you need to be able to install Rails as a gem, not a repo. So it depends on when Rails team publishes some --pre gem at least.

0

Please sign in to leave a comment.