RM do not recognize czech language in Cucumber features

Hi,
I  wrote Rails app with some cucumber scenarios in Czech language ( #language: cs). They all pass.
But when editing them in RubyMine 4.5.4, there is no highliting or code completion.
On attached image ther is  english and czech scenario.
English have highliting, code copletion and recognized undefined step.
Czech have only typo errors.

What I am doing wrong?

  Foton

Attaching the project settings screen too.



Attachment(s):
rb_config.jpg
rb_cc_scenarios.jpg
10 comments
Comment actions Permalink

Hi,

it looks like this is one ove several i18n problems we had with cucumber :(
As a good news this particular problem is fixed in the latest RM 5.0 EAP, so try it ;)

Regards, Oleg.

0
Comment actions Permalink

Hi,
just installed windows version "RubyMine (Enoki) RM-124.524".
RM now highlite SOME keywords, but not all.
Code completion does not work (tried word "Pokud", which is highlited, as "pok"+ <CTRL+SPACE> => "no suggestion").
Highlite of undefined step do not work too.

If I use ENG, everything work as expected. See screenshot.



Attachment(s):
RM5_cucumber_i18n.jpg
0
Comment actions Permalink

Hi Petr,

it looks like RM fails (for some reasons) recognize Požadavek and Scénář as keywords for some reasons (they are not highlighted)
I've attached similar scenario which works fine for me.
Does it works for you?  Could you please attach your version of .feature file which doesn't work.

Regards, Oleg.



Attachment(s):
cs_test.feature.zip
0
Comment actions Permalink

Hi Oleg,

I tested  your feature on my RM 124.524

  • It do not highlite "Požadavek" and "Scénář"
  • "Pokud", "A" , "Pak" are highlited

  1. When I first try code completion on "Po" under last line ("Pak I have two something") then there are suggestions "Požadavek", "Pokud".
  2. I select "Požadavek" and it is written correctly but without colon at end
  3. When I then try on new line completion for "Po" it writes "PoĹľadavek:" (letter"ž" is somehow scrambled) immediately, no menu to select from.
  4. When I then try on new line completion for only "P" it writes "PoĹľadavek:" again immediately, no menu to select from (should be "Požadavek", "Pokud", "Pak").


I done it on fresh new project and instalation of RM without transfering settings to RM 4.5.4 .



Attachment(s):
rb_cs_test_feature.jpg
0
Comment actions Permalink

My testing features in attachment



Attachment(s):
features.zip
0
Comment actions Permalink

What OS version are you using and what are locale settings?

Regards, Oleg.

0
Comment actions Permalink

Windows 7 Home Premium SP1 - czech
Rails locale is set to: I18n.default_locale = "cs"

0
Comment actions Permalink

Could you please try to modify rubymine.vmoptions and add
-Dfile.encoding=UTF-8
to it and see if this will help with the problem.

Regards, Oleg.

0
Comment actions Permalink

Yes, this one do that trick.
RM 5 + adding line "-Dfile.encoding=UTF-8" to ..\RubyMine124.524\bin\rubymine.exe.vmoptions .
Highliting, code suggestion and creating of undefined steps, everything now work.

Thanks a lot for your effort
   Foton

0
Comment actions Permalink

this means we have one more bug :(  could you plaese file a ticket about this (so, you would get notification when the problem will be fixed).

Regards, Oleg.

0

Please sign in to leave a comment.