Debugger prints out breakpoint info instead of stopping

Hi,

Ubuntu 12.04
RubyMine: 4.5.4
Ruby: .1.9.2
Rails: 3.1.5

I set two breakpoints in a controller and when I hit that action the debugger does not highlight-and-stop at the desired lines, rather it prints out the following in the console (I hit "Refresh" 4 times):

Breakpoint 1 at /home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:5
Breakpoint 2 at /home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:7

Breakpoint 1 at /home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:5
Breakpoint 2 at /home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:7

Breakpoint 1 at /home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:5
Breakpoint 2 at /home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:7

Breakpoint 1 at /home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:5
Breakpoint 2 at /home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:7

Can someone help me get the debugger working?

Thanks,
Larry

6 comments
Comment actions Permalink

Most likely this breakpoint does not have Suspend checkbox checked, but has Log message to console one checked. You could change it in Run | View breakpoint (see attached screenshot)



Attachment(s):
Screen Shot 2012-10-10 at 7.10.06 PM.png
0
Comment actions Permalink

Hey Dennis,

Thanks for the quick reply (as usual). Your answer made perfect sense, especially since I didn't even know about those options.

My guess is that a checked "Suspend" and an unchecked "Log message to console" are the defaults; and since I didn't even know about these options I never changed them.

And that is indeed the case: I have the settings that you suggest and they're just not working. Or else they're working backwords, because it is still logging and not stopping.

Thoughts?

Thanks,
Larry

0
Comment actions Permalink

Looks strange, please enable verbose debugger output (Settings | Debugger | Ruby tab) and attach output here.

0
Comment actions Permalink

Hi Dennis,

Here you go.I've also included a snapshot of my settings.

Thanks,
Larry

/home/larry/.rvm/rubies/ruby-1.9.2-p320/bin/ruby -e at_exit{sleep(1)};$stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /home/larry/.rvm/gems/ruby-1.9.2-p320@hengage/gems/ruby-debug-ide-0.4.17.beta14/bin/rdebug-ide --dispatcher-port 56715 --debug --port 47239 -- /home/larry/.rvm/gems/ruby-1.9.2-p320@hengage/bin/unicorn_rails -l 0.0.0.0:3000 -E development
Fast Debugger (ruby-debug-ide 0.4.17.beta14, ruby-debug-base 0.11.30.pre10) listens on 127.0.0.1:47239
Connected from 127.0.0.1
4566: Starting control thread
4566: Processing in control: start
4566: Starting: running program script
I, [2012-10-11T09:51:24.344898 #4566]  INFO -- : listening on addr=0.0.0.0:3000 fd=5
I, [2012-10-11T09:51:24.345231 #4566]  INFO -- : worker=0 spawning...
I, [2012-10-11T09:51:24.345866 #4566]  INFO -- : master process ready
Fast Debugger (ruby-debug-ide 0.4.17.beta14, ruby-debug-base 0.11.30.pre10) listens on 127.0.0.1:50200
Connected from 127.0.0.1
4574: Starting control thread
4574: Processing in control: start
4574: Starting: running program script
I, [2012-10-11T09:51:24.348587 #4574]  INFO -- : worker=0 spawned pid=4574
I, [2012-10-11T09:51:24.348746 #4574]  INFO -- : Refreshing Gem list
DEPRECATION WARNING: class_inheritable_attribute is deprecated, please use class_attribute method instead. Notice their behavior are slightly different, so refer to class_attribute documentation first. (called from require at <internal:lib/rubygems/custom_require>:29)
DEPRECATION WARNING: class_inheritable_attribute is deprecated, please use class_attribute method instead. Notice their behavior are slightly different, so refer to class_attribute documentation first. (called from require at <internal:lib/rubygems/custom_require>:29)
4566: Processing in control: b /home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:5
4566: <breakpointAdded no="1" location="/home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:5"/>
4574: Processing in control: b /home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:5
4574: <breakpointAdded no="1" location="/home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:5"/>
/home/larry/.rvm/gems/ruby-1.9.2-p320@hengage/gems/debugger-1.1.3/lib/ruby_debug.so: warning: already initialized constant VERSION
I, [2012-10-11T09:51:55.540017 #4574]  INFO -- : worker=0 ready
Breakpoint 1 at /home/larry/RubyMine/Hengage/app/controllers/acts_controller.rb:5



Attachment(s):
breakpoint_settings.png
0
Comment actions Permalink

Looks like a conflict between debugger gem and ruby-debug-ide. Could you try removing debugger gem from dependencies?

0
Comment actions Permalink

Great call, Dennis! No way would I have been able to figure that one out.

Thanks a lot, man!

-- Larry

0

Please sign in to leave a comment.