How to turn off "bold" and "background" for all text?

I am checking out RubyMine, and find the default bold text in Ruby, and background colored text in HAML to be excessive. Rather than working through every text type, is there a way to turn off "bold" and "background" for all text types?

Thanks,
Martin

5 comments
Comment actions Permalink

You can save the default color scheme under a new name, open the color scheme file in a text editor (it's stored in XML) and do a search and replace to change the attributes. Unfortunately there is no way to do this through RubyMine UI.

0
Comment actions Permalink

Thanks. Great idea, except I am not finding the file anywhere. Where is it stored?

Martin

0
Comment actions Permalink

http://devnet.jetbrains.net/docs/DOC-1156
(it's obviously not '10' any more, but the rest of the path is the same)

0
Comment actions Permalink

Thank you! On the Mac, the current directory is:        

~/Library/Preferences/RubyMine40/colors

... and the apparent font type for bold is:

<option name="FONT_TYPE" value="1" />

0
Comment actions Permalink

This is an old thread, but it's showing up near the top on 2017 Google searches. I just wasted half a night on this issue, before realizing a trivial fix (on a Mac).

IntelliJ can't display bold if your font doesn't provide bold. I use "Source Code Pro". One can disable Black, Bold, and Semibold through the application "Font Book". Now restart IntelliJ, and it can't display bold in this font, so it doesn't.

I'm sure there is a way to do this on other operating systems.

0

Please sign in to leave a comment.