Debugger crashes when it hits the first breakpoint

That's basically it: when I try and debug anything, the debugger crashes when it hits the first breakpoint. (I put the line 'puts "next line has breakpoint"' right above the line with the break point, as you can see in the attached dump, that line is run (the puts is successful) and then the crash occurs.)

My environment:
  • Ubuntu 10.04
  • Ruby 1.9.2p290   


My ruby debug gems are:
  • ruby-debug-base19x (0.11.30.pre4, 0.11.29, 0.11.28)
  • ruby-debug-ide (0.4.17.beta8, 0.4.17.beta5, 0.4.16)


This happens in both RubyMine 3.2.4 and 4.0 Beta (RM-112.477).  I'm hoping I just have the wrong gem(s), I sure would like to get this to work.

Attached are the crash dump and the result of gem list.

TIA


Attachment(s):
Gems list.txt.zip
Rubymine Debug Crash.txt.zip
18 comments
Comment actions Permalink

More info: I installed the correct version of linecache, according to this post, http://devnet.jetbrains.net/thread/431168, but same problem.

0
Comment actions Permalink

You can try downgrading ruby-debug-base19x to 0.11.30.pre2, if that helps, then it must be the same problem as here RUBY-10280

0
Comment actions Permalink

Thanks for the response. I uninstalled all versions of ruby-debug-base19x and then tried


gem install ruby-debug-base-0.11.30.pre2


Got


ERROR:  Could not find a valid gem 'ruby-debug-base-0.11.30.pre2' (>= 0) in any repository
ERROR:  Possible alternatives: ruby-debug-base19x, ruby-debug-base19, ruby-debug-base




Can you tell me the syntax to use to load it?


Thank you.
0
Comment actions Permalink

Sure. First you should uninstall all versions of ruby-debug-base19x
gem uninstall ruby-debug-base19x
and then install
gem install ruby-debug-base19x -v 0.11.30.pre2
If RubyMine suggests you to update it simply reply no.

Sorry for not providing it in the first post

0
Comment actions Permalink

That worked (the install) and that worked (reverting to the earlier version) ;)

I've used the debugger three times now, stepping thru hundreds of lines, no crashes.  That seems to be the fix.

Thanks again!

PS, I will post again if I do get problems.

0
Comment actions Permalink

Hi - I'm getting this too, and your instructions don't seem to fix the problem. I believe it has something to do with the face that my Gemfile has:  gem "debugger"  also listed -- and this is something I can't remove due to other people using this in my project.

I had RubyMine install the debugging gems it needs when I tried to start the debugger for the first time, and that seemed to work, but as soon as I hit a breakpoint it crashes:

RuntimeError: Debugger.start is not called yet.
/Users/joe/.rvm/gems/ruby-1.9.3-p194@proj/gems/debugger-1.1.3/lib/ruby-debug/processor.rb:130:in `breakpoints'
/Users/joe/.rvm/gems/ruby-1.9.3-p194@proj/gems/debugger-1.1.3/lib/ruby-debug/processor.rb:130:in `at_breakpoint'
(eval):5:in `block in at_breakpoint'
<internal:prelude>:10:in `synchronize'
(eval):3:in `at_breakpoint'
/Users/joe/.rvm/gems/ruby-1.9.3-p194@proj/gems/debugger-1.1.3/lib/ruby-debug-base.rb:41:in `at_breakpoint'
...




Any ideas?
0
Comment actions Permalink

Can you post what you get when you issue this from the command prompt:

gem list ruby-debug



?
0
Comment actions Permalink

*** LOCAL GEMS ***

ruby-debug-base19x (0.11.30.pre10)
ruby-debug-ide (0.4.17.beta9)

0
Comment actions Permalink

fwiw, my looks like:

ruby-debug-base19x (0.11.30.pre10, 0.11.30.pre2, 0.11.28)
ruby-debug-ide (0.4.17.beta8, 0.4.17.beta5, 0.4.16)


the only significant (and I use that term lightly) difference is, I'm using 0.4.17.beta8 for the ide, you've got beta9.  STill, might be worth a shot.
0
Comment actions Permalink

I'm pretty sure the problem is that:  gem "debugger" is also in my Gemfile (and is used by others on my project).

If I remove the "debugger" gem, everything works fine.

0
Comment actions Permalink

yep, it is a know problem that two debuggers conflicts :(

0
Comment actions Permalink

Is it possible to command-line debug with a set of gems that also allows RubyMine to continue supporting graphical debugging via the IDE? If so, what combinations of gems do I need?

0
Comment actions Permalink

+1 would be nice to support both - on our team we have some that use TM and debug from terminal, others (the smart ones :) ) use RM and would like to debug within the IDE. But we fight over the gemfile.

0
Comment actions Permalink

We're working on that currently. As a workaround you can use following code (since 4.5):

gem 'ruby-debug' unless ENV['RM_INFO']

0
Comment actions Permalink

YES! Finally I can debug again with RubyMine and not piss off the rest of my team by removing their love of "debugger" :)

0
Comment actions Permalink

Thank you Dennis - works great!:)

0
Comment actions Permalink

Actually I think there is a small problem. It seems like RubyMine is constantly changing our Gemfile.lock to remove the "debugger" gem lines.  This results in continual back-and-forth modifications to Gemfile.lock between me and other non-RubyMine devs.

Anyone else seeing this?

0
Comment actions Permalink

Yup - just noticed this today too... :/

0

Please sign in to leave a comment.