Startup Crash in 4.5.2

Since upgrading to 4.5.2 yesterday, I'm seeing crashes on startup of RubyMine.  I've tried downloading the complete 4.5.2 version and am seeing the same issue.  My trial copy of PhpStorm is still working, so it's an issue with RubyMine rather than Java or the underlying system.

This is on a Debian AMD-64 system, the backtrace and memory map vary on each run, but I'm always seeing the invalid next size error below:

➜  bin  ./rubymine.sh
Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)
*** glibc detected *** /usr/lib/jvm/jdk1.7.0/bin/java: free(): invalid next size (fast): 0x00000000027641d0 ***



One backtrace looks like this:

======= Backtrace: =========
/lib/libc.so.6(+0x71bd6)[0x7fe73faa7bd6]
/lib/libc.so.6(cfree+0x6c)[0x7fe73faac94c]
/usr/lib/jvm/jdk1.7.0/jre/lib/amd64/server/libjvm.so(+0x7dd42d)[0x7fe73f56f42d]
/usr/lib/jvm/jdk1.7.0/jre/lib/amd64/server/libjvm.so(+0x7dc28e)[0x7fe73f56e28e]
/usr/lib/jvm/jdk1.7.0/jre/lib/amd64/server/libjvm.so(JVM_FindClassFromBootLoader+0x13b)[0x7fe73f30081b]
/usr/lib/jvm/jdk1.7.0/jre/lib/amd64/libjava.so(Java_java_lang_ClassLoader_findBootstrapClass+0x9c)[0x7fe73e4dabec]
[0x7fe739a8bbb1]

Please sign in to leave a comment.