Annotate option is not available for .rabl file (GIT)

For some reason, the Annotate option (VCS: Git: Annotate, or right click in left gutter for Annotate) is not available for .rabl files.  I can view the git history (VCS: Git: Show History) and compare revisions from there, but not sure why annotate is disabled.

Thanks,
Mark

RM 4.5, OSx 10.7.4

2 comments
Comment actions Permalink

Please make sure that the extension is associated with some file type (at least "Text files") in Settings | File Types.

0
Comment actions Permalink

Thanks for the super-fast response. I confirmed that *.rabl is already listed under Preferences: File Types: Text Files. I removed it, closed RM and re-opened expecting RM to prompt me for the file type when opening it. I did not :/   I checked all the other file types to see if .rabl was listed there, but not luck. If I associated *.rabl with Ruby file then Annotate displays. If I associate it back w/ Text file it does not. So, I left it as Ruby and can annotate - not sure why Text won't.

My Ignore these files and folders is set to: CVS;SCCS;RCS;rcs;.DS_Store;.svn;.pyc;.pyo;*.pyc;*.pyo;.git;*.hprof;_svn;.hg;*.lib;*~;__pycache__;.bundle;*.rbc;

0

Please sign in to leave a comment.