Login to GitHub

I am using RubyMine 4.5 EAP 118.614 although I have also tried and failed with RubyMine 4.0.3 117.230 on Mac OS X 10.7.4

When I try to set my GitHub credentials from Preferences->GitHub or go to VCS->Import Into Version Control->Share Project On GitHub

I set

Host: github.com
Login: carlclarke
Password: ****

I get a message in the Login to GitHub dialog saying:

Cannot login with given credentials (with a thunderbolt beside it)

I have tried both my GitHub user id and my email address registered to GitHub although from googling I understand that the GitHub user id is the correct choice.
I have set up git as per the notes on GitHub setting my name and email address and gone through checking/reseting the ssh key as per:

https://help.github.com/articles/generating-ssh-keys

I performed the test:

ssh -T git@github.com

and it returns the correct response:

Hi carlclarke! You've successfully authenticated, but GitHub does not
# provide shell access.

Does anyone have any suggestions on how I can fix this? I seem to rememeber it working some time ago so I am wondering if some settings have become polluted.

Regards


Carl Clarke

8 comments
Comment actions Permalink

I'm getting the same thing, Cannot login with given credentials (with a thunderbolt beside it), in RubyMine 4.0.3 117.230 on Ubuntu 10.04.  My credentials work everywhere else.

0
Comment actions Permalink

Most likely the problem you see is tracked as http://youtrack.jetbrains.com/issue/IDEA-85769 (see couple recent comments).
It looks like GitHub EOLed v1 nad v2 APIs and we have to start using v3 API.
Hope this will be fixed soon.

Oleg.

0
Comment actions Permalink

I am having the same experience using RubyMine 4.0.3 117.230 on Mac OS X 10.7.4.  Is there any news of a solution from Rubymine since you first posted?
Cheers,
David Handel

0
Comment actions Permalink

The problem has been fixed in RM 4.5 beta.

Oleg.

0
Comment actions Permalink

Thanks Oleg.  It works.
David

0
Comment actions Permalink

Where can I download a copy of the 4.5 beta?

0
Comment actions Permalink

Thanks.  Fixed the problem.

0

Please sign in to leave a comment.