Cannot connect to the debugged process at port 49536 in 10s:

After upgrading the EAP RM to 118.614 this morning I could no longer debug.

At first RM tried (re)installing the gem, to no avail.
After multiple attempts, I manually removed all the ruby-debug** gems so RM could reinstall from a clean sheet, but I now get another error message :
    Cannot connect to the debugged process at port 49536 in 10s:

Stacktrace (from the dialog)

Cannot connect to the debugged process at port 49536 in 10s:
Error Output:
/Users/alain/.rvm/gems/ruby-1.8.7-p358/gems/ruby-debug-ide-0.4.17.beta11/lib/ruby-debug-ide/command.rb:32: uninitialized constant Class::DEF_OPTIONS (NameError)
 from /Users/alain/.rvm/rubies/ruby-1.8.7-p358/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
 from /Users/alain/.rvm/rubies/ruby-1.8.7-p358/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
 from /Users/alain/.rvm/gems/ruby-1.8.7-p358/gems/ruby-debug-ide-0.4.17.beta11/lib/ruby-debug-ide/ide_processor.rb:2
 from /Users/alain/.rvm/rubies/ruby-1.8.7-p358/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
 from /Users/alain/.rvm/rubies/ruby-1.8.7-p358/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
 from /Users/alain/.rvm/gems/ruby-1.8.7-p358/gems/ruby-debug-ide-0.4.17.beta11/lib/ruby-debug-ide.rb:9
 from /Users/alain/.rvm/rubies/ruby-1.8.7-p358/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
 from /Users/alain/.rvm/rubies/ruby-1.8.7-p358/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
 from /Applications/RubyMine EAP.app/rb/gems/debug_preloader.rb:2

\

Any idea what happeneddd/to do next?

Alain
9 comments
Comment actions Permalink

Hi, Alain
Please try to check the option Run the script in context of the bundle (bundle exec) in Run/Debug configuration dialog. You can find this option on the tab Bundler. If it does not help, please submit the issue in our bugtracker

0
Comment actions Permalink

Anna,

Unfortunately the [Run the script in context of the bundle ] option is correctlly checked.
I wish it were that simple :(

Alain

0
Comment actions Permalink

Hi Alain,

Perhaps you have the same problem as discussed here http://devnet.jetbrains.net/thread/436621?tstart=0

Regards, Oleg.

0
Comment actions Permalink

Oleg,

Unfortunatelly not; I had already checked those points :

  • removed all breakpoints
  • firewall is off
  • computer has a name on the network


Additionally, it worked find with the previous EAP version.

0
Comment actions Permalink

btw, even though the message says ' could not connect in 10 seconds' , it shows immediatly.

I reverted to the previous EAP version and the same faulty behaviour is plaging me (unline before the upgrade, where debugger worked fine)

0
Comment actions Permalink

Then, perhaps, the problem is not in the version of RM, but in version of o
ne of debugger's gem?

0
Comment actions Permalink

In $GEM_HOME/gems/ruby-debug-ide-0.4.17.beta11/lib/ruby-debug-ide/command.rb do the following, change line 27 from:

27       DEF_OPTIONS ||= {
28         :event => true,.
29         :control => false,.
30         :unknown => false,
31         :need_context => false
32       }



to

27       unless defined? DEF_OPTIONS
28         DEF_OPTIONS = {
29           :event => true,.
30           :control => false,.
31           :unknown => false,
32           :need_context => false
33         }
34       end



The DEF_OPTIONS issue was caused because the "assign if false" operator coudn't find the constant.  Apparently Ruby-1.8.7-pwhatever fails on undefined constances with "||=".
0
Comment actions Permalink

I confirm : this fixed the problem for me

Thanks Chris

0

Please sign in to leave a comment.