Rubymine & Git - going insane trying to get it working

Hi,

I am new (to Rubymine) and am trying to upload my project to git. I did the following:

1. Create new rails project
2. VCS/Import to version control/Share project on Git
3. Type name of project etc, green bubble says it went ok
4. I check on Git and there is NOTHING there except the directory and a readme file ("This file was created by JetBrains RubyMine 4.0.3 for binding GitHub repository")
5. Push says nothing to push, I've tried adding, committing etc nothing I do puts the project files up there

I've been at this 3 hours now. I have deleted projects on both sides and started again with a new project name. Nomatter what I do I cannot get it to upload. It can create the initial directory, with a readme, but that's it. No error messages in the log. As far as Rubymine is concerned there is nothing to push.

It's driving me absolutely nuts - I'm ready for throwing the computer out the window I'm that mad. Sorry, but it's just so frustrating. I know it is probably my lack of knowledge, but I can't see what I am doing wrong.

Thank you very much if you can put me out of my misery - I don't want to go to bed with this still not done as I know I won't sleep :)

Kevin

2 comments
Comment actions Permalink

I should add, it only ever seems to commit the .idea directory. It ignores everything else.

This is a brand new project with all those files to upload. But it doesn't want to upload anything apart from a readme... going... to... kill... it....

0
Comment actions Permalink

I solved it.

I wasn't seeing the message that said it was refusing to do anything because I had not entered a commit message. If this had been output in the event log I might have noticed. All I got was "no changes can't push bye"

I then notice that it had found 56 code errors in the blank template that it created itself, a new project. I just ignored this.

I have to say that I have only been using this a few hours, but the IDE seems like it would be great for those that know how it works. If you are new to it, most things seem very obtuse. The help documentation also assumes that you already know everything. For instance, there is no mention of commit messages, and I would not have thought of it until I spent hours looking and eventually though.... hold on, what if I haven't entered a default commit message?

All in all, this IDE is in need of some attention I think. Everything I have had tried to do with it so far has been a fight. Right from the start when it wouldn't even install missing GEMs and I had to do the installs manually. Not impressed.

0

Please sign in to leave a comment.