[Ruby Plugin] Created new Rails project, views/assets/etc don't show up

Hi, I just started trying to use the IntelliJ IDEA Ultimate edition Ruby plugin because I saw it was supposed to basically be feature equivalent to RubyMine and since I use IDEA a lot for Java as well I figured I'd just buy the ultimate edition and use plugins instead of buying RubyMine separately. However, when I create a new project from my existing Rails source, only the Ruby files are imported into the project, so for example none of the views or assets (where javascript files are stored in our project) are showing up, and I'm not sure how to get them. I might just be missing something really obvious though. Any help is greatly appreciated! Here's a screenshot of what's going on:
http://i.imgur.com/g6BSW.png
I tried searching the forums to figure out what was going on, and someone seemed to say that the views should be under the controller they correspond to, but it doesn't seem to work like that at all as I can't expand the controllers in any way. I also tried the Rails view instead of the Project view, but that's even more useless as anything I click on kicks me back to the Project view.

controllers.png
railsview.png

2 comments
Comment actions Permalink

Hmm, just after asking I solved my own question! I decided to try making a new project to see how it would go, found that it didn't find my rails gem (not sure if it couldn't find it because it was using bundler and rvm), but I had it install a Rails gem anyway and then found that I could actually create a project from existing source through that. Seems like if I just make a project from existing sources in the top level new project window it only makes it a ruby project and not a rails project. This seems a little counterintuitive, but I'm glad I figured it out.

0
Comment actions Permalink

Hello Ibrahim,

this looks like a quite old problem

0

Please sign in to leave a comment.