'try_do': The complier failed to generate an executable file. (RuntimeError) You have to install development tools first. '

Hi,

I am getting the following error when I am trying to install a gem - any ideas what is missing?

Following gems were not installed:
nokogiri (1.5.0):  Error installing nokogiri:
 ERROR: Failed to build gem native extension.          /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/bin/ruby extconf.rb checking for libxml/parser.h... *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers.  Check the mkmf.log file for more details.  You may need configuration options.  Provided configuration options:  --with-opt-dir  --with-opt-include  --without-opt-include=${opt-dir}/include  --with-opt-lib  --without-opt-lib=${opt-dir}/lib  --with-make-prog  --without-make-prog  --srcdir=.  --curdir  --ruby=/Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/bin/ruby  --with-zlib-dir  --without-zlib-dir  --with-zlib-include  --without-zlib-include=${zlib-dir}/include  --with-zlib-lib  --without-zlib-lib=${zlib-dir}/lib  --with-iconv-dir  --without-iconv-dir  --with-iconv-include  --without-iconv-include=${iconv-dir}/include  --with-iconv-lib  --without-iconv-lib=${iconv-dir}/lib  --with-xml2-dir  --without-xml2-dir  --with-xml2-include  --without-xml2-include=${xml2-dir}/include  --with-xml2-lib  --without-xml2-lib=${xml2-dir}/lib  --with-xslt-dir  --without-xslt-dir  --with-xslt-include  --without-xslt-include=${xslt-dir}/include  --with-xslt-lib  --without-xslt-lib=${xslt-dir}/lib /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/mkmf.rb:368:in `try_do': The complier failed to generate an executable file. (RuntimeError) You have to install development tools first.  from /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/mkmf.rb:452:in `try_cpp'  from /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/mkmf.rb:853:in `block in find_header'  from /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/mkmf.rb:693:in `block in checking_for'  from /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/mkmf.rb:280:in `block (2 levels) in postpone'  from /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/mkmf.rb:254:in `open'  from /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/mkmf.rb:280:in `block in postpone'  from /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/mkmf.rb:254:in `open'  from /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/mkmf.rb:276:in `postpone'  from /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/mkmf.rb:692:in `checking_for'  from /Users/muratcetin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/mkmf.rb:852:in `find_header'  from extconf.rb:96:in `'   Gem files will remain installed in /Users/muratcetin/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0 for inspection. Results logged to /Users/muratcetin/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/ext/nokogiri/gem_make.out



thanks in advance,
Murat
2 comments
Comment actions Permalink

Hello Murat,

this may happen due to the way OS X handles environment variables, please see this tip on how to setup environment variables to be picked up by RubyMine

0
Comment actions Permalink

Hi Dennis,

In my case, installing another version of GCC bundled here (https://github.com/kennethreitz/osx-gcc-installer/blob/master/README.rst) helped. I tried updating it from other sources to no avail as well.

thanks for your reply,
Murat

0

Please sign in to leave a comment.