Spork, EAP 112-219, Ruby 1.9.2, Debugger not stopping

Spork makes a huge difference in rspec performance when running 1.9.2. However, the debugger does not stop on break points when using spork.

I tried with including and not including the ruby-debug19 gem in the gemfile.

Any suggestions? Known problem?

Thanks,

Justin

5 comments

Which run configuration do you debug? Spork server actually executes your code, so if you need to debug your application(instead of some spork classes) you need to launch spork server in debug mode.

0

Please clarify the steps. Like start spork in debug mode, then run tests? Can the tests be run in regular mode with spork in debug mode?

Thanks.

0

1. Tools | Run Spork DRb Server..  -> press "Run" then stop the configuration
2. During step 1) RubyMine created temporary "[Cucumber/RSpec/TestUnit]: Spork Drb server" run configuration. Launch it using (e.g. debug button)
3. Run your test in regular mode. Debugger will stop server process on breakpoints in test.

0

Under what circumstances do we need to stop and restart spork? Such as any changes to model files?

0

Roman,

When I run spork using debug mode, and then run my spec the debug window opens for the spork process, however it shows no stack frames and no ability to actually debug. Is there some additional configuration I need to do?

I did not uncomment the following section from spec_helper as it lead to issues with having to include the ruby-debug gem, which lead to conflicts with rubymine.

#uncomment the following line to use spork with the debugger
#require 'spork/ext/ruby-debug'

0

Please sign in to leave a comment.