Rubymine 4.0.1 not all files showing up, all root level fields and no run configurations

I tried deleting .idea and restarting but to no avail. When I goto File->Open Directory... and then into my directory the Project window only shows the top level files and I have no run configurations. When I go into project settings Project Structure it is empty. What is going on? This worked just an hour ago. I deleted the directory and then repulled form our GIT repo on the command line and now RubyMine doesn't work. Deleted .idea and restarted still the same problem. I didn't expect this to prevent me from developing for the rest of the day and something so trivial I thought the IDE would be able to handle it. None of the directories inside the directory I pointed to in "Open Directory..." show up.



Attachment(s):
Screen Shot 2012-02-21 at 1.21.23 PM.png
1 comment
Comment actions Permalink

I resolved this by doing what I thought I already did but I must've did this out of order.

Close RubyMine
Remove ./idea folder
Restart RubyMine
Chose File->Open Directory...

And everything is back to normal

0

Please sign in to leave a comment.