Remote Debug

I have remote debug starting and connecting and it was working.  I had to reinstall my remote machine and now it doesn't work anymore.

Rubymine says it is connected, but breakpoints do not work.  If I click a breakpoint it waits 5 seconds, then times outs.  The breakpoint is in the IDE, but does not pause execution.

What are the required gems or other requirements on the remote?

I have:

rdebug (0.1)
ruby-debug-base19 (0.11.25)
ruby-debug-base19x (0.11.29)
ruby-debug-ide (0.4.16)
ruby-debug19 (0.11.6)


This is my command line which does succesfully connect
rdebug-ide --port 1234 -h 0.0.0.0 -- /usr/bin/rails server
12 comments

Any support from Jetbrains?   I tried with EAP, same thing.  Big pauses when trying to add a breakpoint which doesn't do anything.

0

Please uninstall all your ruby-debug* gems, remove them from gemfile and let RubyMine to install these gems automatically. I recomment latest RubyMine 4.0 EAP for this.

0

Also please attach idea.log file, you can find it using RubyMine | Help | Reveal Log in Finder action.

0

I don't have any ruby debug gems in the Gemfile.  That is actually a problem on a remote machine because Rubymine cannot install automatically.  As I said, it was working before and then I had to reinstall the remote machine.  I belive the gem versinos are the same because I posted a snippet on this forum and it had my gem versions.

As I said, Rubymine is able to connect to the remote debug instance which launches Rails server.  But breakpoints don't work.  I wlil post the debug log later today when I get home.  

0

There was nothing in the log:

Only this on occasion:

2012-01-13 20:40:29,476 [1077785]   INFO - s.impl.stores.FileBasedStorage - Document was not loaded for $APP_CONFIG$/consoleFolding.xml file is null
2012-01-13 20:40:29,476 [1077785]   INFO - .impl.stores.XmlElementStorage - Document was not loaded for $APP_CONFIG$/consoleFolding.xml


2012-01-13 20:33:46,978 [ 675287]   INFO - plication.impl.ApplicationImpl - Not enough pooled threads; creating one at:
java.lang.Throwable
 at com.intellij.openapi.application.impl.ApplicationImpl$1.newThread(ApplicationImpl.java:147)



I am running Windows Rubymine and trying to connect to an Ubuntu remote debug.  I don't understand how it used to work and even what is wrong with it now.  Why would it hold when a breakpoint is added, there is no breakpoint added message on the remote debugger?
0

I uninstalled extra debug gems on the remote machine.

This is all that's left:

gem list | grep debug
ruby-debug-base19 (0.11.25)
ruby-debug-ide (0.4.16)



Can we get a proper set of instructions for remote debug?  I don't know why it's connecting but not working.
0

Again any help from Jetbrains?

0

Please install latest versions of ruby-debug-base19x and ruby-debug-ide with --pre flag:
gem install ruby-debug-base19x --pre
gem install ruby-debug-ide --pre

0

I uninstalled existing versions of those gems and installed the --pre's, still same thing:

gem list  | grep debug
ruby-debug-base19x (0.11.30.pre6)
ruby-debug-ide (0.4.17.beta8)


There should be some instructions for a remote debug.  I don't know how it worked for me before though.
0

Any help on this? I have tried all of these suggestions, with 3.x and with EAP. Nuthin. Can't get a breakpoint to hit. Rubymine debugger says connected  but nothing else.
I'm confident that I'm doing something wrong/stupid but don't really have much in the way of comprehensive instructions. Any help from the fine peeps at JetBrains?

My sincere thanks!

0

Could you please attach versions of the gems on the remote side (linecache19, ruby-debug-base19x, ruby-debug-ide) and on the local machine.
Also, please attach screenshot of your remote debug configuration

0

Please sign in to leave a comment.