EAP112.477 finally dropped support for 1.8.6 then?

Hi guys,

Not sure if it was intentional or not, but Ruby 1.8.6 will no longer work with the latest eap release..

112.291 has been working fine using the following gems:
ruby-debug (0.9.3)
ruby-debug-base (0.9.3)
ruby-debug-ide (0.1.9)

After applying the latest eap I can no longer use the debugger.

The latest eap just keeps popping up an rdebug-ide executable does not exist error when it actually still does.

Is only a couple of legacy programs I maintain on my end that still use Ruby1.8.6, understand if you finally want to drop support for it but I just thought it weird that it worked in the last release and not this one and perhaps a bug had been introduced.

Anyways, just thought you should know, keep up the good work guys.

Lucas

4 comments
Comment actions Permalink

Applied the 112.661 patch today "hoping" to see a fix for this... :( sad day..


Any chance you guys could take a look at this? Or at least advise on how to get the debugger working with Ruby 1.8.6 now? Up until these last 2 beta releases it used to work fine..

0
Comment actions Permalink

Lucas, do you have linecache gem installed?

0
Comment actions Permalink

No I didn't have that installed. But I didn't previously either and it used to work fine.

Was this dependency on linecache added recently? I didn't see it in the release notes.

Oh well, thanks for the reply Dennis, installing linecache -v 0.42  fixed the problem and the debugger now works again.

Thanks!

0
Comment actions Permalink

We add debug related gems lib folders to load path in order to workaround some problems with bundler and cli debugger. Linecache dependency was added quite a while ago to debugger gem, but we added it to loadpath only recently, because it wasn't causing troubles until ruby-debug-base 0.10.5.rc release. I'll remove this check in 1.8.6 case

0

Please sign in to leave a comment.