How to disable autosave (RM4 EAP 112.219)?

How do you turn off the autosave?  
I've tried deactivating all under 'synchronize' in {{File > Settings > General}}

The autosave prevents one from using any Guard.

8 comments
Comment actions Permalink

There is no way to disable the autosave, and I don't quite see how the autosave prevents one from using anything.

0
Comment actions Permalink

duplicate msg deleted

0
Comment actions Permalink

OK, then please either:
a) please reverse this change in behavior, allowing a user to save such that the Guard recoignized inotify events are triggered.
b) and (possible?) use a way of auto-saving that triggers inotify events that guard ignores.

In non-trivial projects, it is critical that users have control over when a save is triggered.
Specifically, when working on a feature file or code I save when I have a fragment of code that does not break the app, e.g a complete line.
Then on save cucumber || rspec is run.
At the moment these Guards are triggered randomly by RM and often break the guard.

Even without using Guard it is not polite to remove a users ability to control when material is saved
http://youtrack.jetbrains.net/issue/RUBY-9903?projectKey=RUBY&query=guard

0
Comment actions Permalink

duplicate msg deleted

0
Comment actions Permalink

Reverse which change in behavior? Autosave has always behaved in the same way.
You may want to turn off the "Safe write" feature in Settings | General - this will cause RubyMine to save changes directly to the original file, not through an intermediate file.
Also note that autosave generally doesn't happen at random points in time. Unless you've enabled autosave by timer under Settings | General, RubyMine saves files only when specific operations are performed, such as running a project, committing files to the version control or deactivating the RubyMine frame.

0
Comment actions Permalink

In earlier RM releases I had autosave turned off, see the intsructions on the Guard page[0].  
Then the tab was asterisked if a change had been made and not saved.
This behavior is no longer present.
Currently, every change I make seems to trigger a save:
- the tab is never asterisked.
- the project pane has a 'busy' cartwheel appear in upper right corner everytime I type somthing.

My settings are shown in the screen shot.

From what you say this behavior sounds like a bug?


[0]: https://github.com/guard/guard/wiki/Analysis-of-inotify-events-for-different-editors



Attachment(s):
Screenshot-Settings.png
0
Comment actions Permalink

Am I correct that the current behavior has changed from previously observed, and so this is a bug?

0
Comment actions Permalink

If RubyMine indeed behaves the way you describe, then it's indeed a bug. I don't observe such behavior on my machine.

0

Please sign in to leave a comment.