Firing up Firefox from Rubymine

Hi,

Just wondering if anyone has experienced this same problem and might have an answer...

I recently upgraded both Ubuntu (to 11.10) and Firefox (to 8.0), so I'm not sure which one (if any) is the culprit. In my Run>Config dialog box I have the following settings for firing up my (Thin) server:
IP Address: 0.0.0.0
Port: 3000
Run browser: checked
Run browser field: http://0.0.0.0:3000

This config has worked for as long as I can remember, however, now when I fire up the server Firefox still gets started, but I get a "Firefox can't find the server at www.%u.com" error.

Any ideas?

Thanks,
Larry

4 comments

Hi Larry,
what version of RubyMine are you using?

0

Hi Dennis,

The latest (and greatest!) I believe: 3.2.4 #RM-107.612

-- Larry

0

I don't know as I haven't installed it. I wouldn't mind trying - do you think it's stable enough to start using?

Regarding my problem, it's only a minor annoyance as once the browser is up I just go to http://localhost:3000 and everything is fine. I was just hoping for an "Oh yeah, the same thing happened to me and here's what I did to fix it ..." type of answer.

Thanks,
Larry

P.S. I just installed 4.0 and the problem remains. I think it's either an Ubuntu or Firefox (or combination) problem, and, like I said, it's not that big a deal. I'm sure you guys have a ton of stuff to do for the new release, so don't waste any time on this. I'll continue to use 4.0 and hopefully will be able to provide some useful feedback. Thanks again for a GREAT IDE!

P.P.S. Okay, I have a desktop running 64-bit Ubuntu 11.04 and a laptop running 32-bit Ubuntu 11.10. Both have Firefox 8.0 and now the new Rubymine 4.0. When I run my (Thin) web server it works fine on the desktop but not on the laptop - that's where I get the "Firefox can't find the server at www.%u.com" error message. Which leads me to believe that the problem is due to the newer Ubuntu version. Hope that helps.

0

Please sign in to leave a comment.