cucumber language support active ?

Hello,

Is there a way to have the other-language-than-english cucumber keywords recognized ?
French keywords on .features files with # language: fr are not recognized but english keywords and steps completion work as intended.
See capture


Ruby Plugin 3.2 installed on intellij IDEA 10.5 ultimate.
Project using cucumber through the maven plugin cuke4duke and jruby.

Thanks for your help



Attachment(s):
capture-cucumber-ruby-plugin.png
7 comments
Comment actions Permalink

Have you configured JRuby facet for your Java module in Project Settings? Is JRuby SDK set? Is "cucumber" gem attached to module in jruby facet settings? Ruby plugin knows how to parse # language tag and it fetch keywords from your JRuby/Ruby SDK cucumber gem. If sdk isn't set or gem isn't attached, please fix it and restart IDEA.

0
Comment actions Permalink

Thanks for your answer, I have installed Jruby SDK, cucumber gem and configured them in intellij (see capture).
Unfortunately, the "# language: fr" still seems not to be taken into account. Only english keywords available in autocomplete.
Any other advice ?



Attachment(s):
capture-config-jruby-cucumber-idea.png
0
Comment actions Permalink

Err after a last tweak in the facets ... in fact it works !!!
Many thanks for your help Roman :)

0
Comment actions Permalink

Many thanks for your help Roman :)

Develop with pleasure!

P.S: Please don't forget to add JRuby(Or JRuby & Rails) facets to Java modules in future. These facets enable Ruby/Rails support features.

0
Comment actions Permalink

What did you do? I have the same problem.

S:)cucumber.png

0
Comment actions Permalink

Roman gave the best answer :

"Have you configured JRuby facet for your Java module in Project  Settings? Is JRuby SDK set? Is "cucumber" gem attached to module in  jruby facet settings? Ruby plugin knows how to parse # language tag and  it fetch keywords from your JRuby/Ruby SDK cucumber gem. If sdk isn't  set or gem isn't attached, please fix it and restart IDEA."

In your facets settings, under JRuby, you can create a new facet on your module which contains the ruby source and cucumber .feature files.
This facet must have a JRuby SDK set, with the cucumber gem installed.

During the installation of the cucumber gem, if the list of the gem doesn't refresh and display the newly installed ones, just restart idea and it should refresh.

Anywway restart idea and it should work.

0
Comment actions Permalink

Thank you.
I think I did all the configurations, but it didn't work.
My project is actually not a java project, but a ruby project.
I ended up with swiching to RubyMine, which works better, but not perfect yet.
http://devnet.jetbrains.net/thread/360617

Anyways.. thanx for answering :)
Silje

0

Please sign in to leave a comment.