How do I change the font for the project view (the file list)

I can't seem to get at the font settings for the project view (alt-1).

I've fiddled with settings > appearance > override default fonts, but that does not seem to change the content of the project view. It only changes the project view's "window title" and the "tabs" that switches between Changes, Todo, etc.

Also, settings > editor > Colors and Fonts > Font settings only affects text in the editor.

Is there a third place that I am missing?

2 comments
Comment actions Permalink

Hello nobashi,

Changing system font for applications made the trick for me.

Regards,
Oleg

0
Comment actions Permalink

Hi Oleg,

Thanks for your answer.

Not sure if you guessed / remembered it, but I am running Ubuntu.

Setting the Ubuntu System Settings > Appearance > Fonts > Application Font option did indeed influence the fonts in the project view (mainly file names), however not as I had anticipated:

The font face does not seem to change to reflect different settings in Application Fonts. But changing the font to a random other font and then back to the 'Ubuntu' font fixed missing unicode characters for Japanese (some characters in filenames were being rendered as a square). Perhaps setting the font rewrites a fontconfig file somewhere, making swing use another font for rendering Japanese. So many questions...

I have to say that I find font settings to be a bit confusing overall, and font rendering non-satisfactory, especially for small sizes (less than 18pts). I know it's a swing issue, but I wish that Jetbrains would try to solve the issue somehow.

I know I could file a bug report myself, but when I last looked into this, there was already a bunch of dead-end tickets receiving no love from Oracle (I think it was Sun at that time). My guess is that an inquiry by Jetbrains would carry more weight than that of a single user.

Oleg, thanks for solving my immediate problem though (missing unicode characters) :)

0

Please sign in to leave a comment.