How do I restore off screen/hidden windows on a currently non-existant second monitor? (RubyMine 3.2.4 on Win7)

Hello,

When my laptop is docked I have a second monitor connected.
I am currently using just the laptop though and noticed that my Find/Replace and Settings windows are still located on the currently non-existing second monitor.

I tried Window > Restore Default Layout, but that did not fix it. I checked the help and tried searching for a solution, but I can't seem to find anything to address this.
These windows do not show up as separate application windows under RubyMine in Windows 7.

I am running RubyMine 3.2.4 on Windows 7.

Has anyone run into this? Please let me know if you have a solution to this problem.

Thanks,

  -Marc

13 comments

Cunning use of keyboard short-cuts is the answer:

  • Alt-Tab the right window to the foreground
  • Alt-Space to bring up the system menu for the active window (you won't be able to see this)
  • Down arrow once to select 'Move' (again, it's out of view)
  • Enter to select the menu item
  • Down arrow to start the window move
  • Mouse movement then will 'spring' the window into view.

If it doesn't work the first time, it's usually because you accidentally nudged the mouse whilst doing the keystrokes, so try again.

I normally have a twin head setup, but sometimes need to take one of the monitors off and come across this problem quite frequently.

On Linux (Ubuntu at least) you have to go down twice to micj 'Move', but it still works whichever OS I have loaded. :)

Hope that helps.

24

I have the same problem with IntelliJ on XFCE on Debian. Pressing Enter or Space bar puts focus back to the parent window, so this doesn't work for me.

I can reposition main windows visible on the XFCE task bar. To my mind child windows should either be positioned relative to their parent, or should appear in their own right on the task bar. The current situation makes it difficult to reposition off-screen child windows.

0

@Paul,

sorry for the delay. It appears to be a known problem:

https://youtrack.jetbrains.com/issue/IDEA-153291

You can also vote for it so that you receive notifications regarding its state.

0

It is Simple to fix: close webstorm-> go to the folder of the project that your opening upon webstorm launch -> go into the folder ".idea" -> delete workspace.xml -> open webstorm again -> you just need to fix your views in webstorm which anyone can do.

0

@Ryan,

That's a drastic fix.

Mine is over 2200 lines long, and I believe there's just one setting relevant to this issue:

<component name="ProjectFrameBounds" extendedState="6">
<option name="x" value="1960" />
<option name="y" value="12" />
<option name="width" value="1914" />
<option name="height" value="990" />
</component>

I do not want to lose the rest.

This setting does not affect the initial "Did you know?" window. I quite like that feature, when I can see the window and click on it to clear it.

I reckon JetBrains can do better than that.

Cheers

Paul

0

Yes, so, from the comment above, setting

<option name="x" value="1960" />
<option name="y" value="12" />

 

to 0/0, like this

<option name="x" value="0" />
<option name="y" value="0" />

 

should put the window within available one.

0

Hi @Djolecorp,

No. That setting affects the main project window. Popups like the "Did you know" are not affected by this. I think popup windows such as "Did you know" should behave in one of two ways:

1. Positioned *relative* to project windows, so changing the option in workspace.xml does affect it.

2. Appear in taskbar in its own right, so I can use the Move command in my window manager.

Neither of these is happening at the moment.

Cheers

Paul

 

0

Mouse over the CLion icon on the task bar.

Right click in the mini-window that appears just over the icon.

Select "maximize"

3

@Pete,

At least in my environment (XFCE on Debian), secondary windows such as "Did you know" or the prompt for an SSH key *do not appear* in the taskbar.

I think this is an either-or situation. Either secondary windows should be positioned relative to the primary *or* they should appear in the taskbar in their own right. The crux of the problem is that neither of those things are happening, so normal window manager tools for positioning are not available to me.

Cheers

Paul

0

Hi again,

I have just noticed that diffs such as "Compare with same repository version" create a secondary window that *is* listed on the taskbar, so it's much easier to move even when positioned off-screen.

It seems to me that secondary windows are or are not listed in the taskbar depending on whether they are "big" (e.g. diff) or "small" (e.g. Tip Of The Day, enter SSH key). That seems very arbitrary. Is there any rhyme or reason to it?

Cheers

Paul

 

0

"Mouse over the CLion icon on the task bar.

Right click in the mini-window that appears just over the icon.

Select "maximize""

 

Thanks Pete, that worked for me on win 10.

0

@Lthoie, for me at least, secondary windows like the Tip Of The Day *do not* appear in the taskbar. If they did, I would have tools to move them. I repeat...

Either secondary windows should show up on the taskbar so normal window manager tools can be used to move them around *or* they should be positioned relative to the main window. At present neither of those things are happening.

0

Please sign in to leave a comment.