RubyMine 3.2.2 and green_shoes: "require green_shoes" fails to load?

Well, sorry I guess this could be a simple one for someone knowing how RubyMine deals withloading libs -but for me as a RM newbie, it is unsolvable..

I'm running RubyMine 3.2.2 and am trying to use green_shoes; the green_shoes gem installed via RM's settings dialog fine: a "gem list" on the cmd line results in that:

*** LOCAL GEMS ***


atk (1.0.0 x86-mingw32)

cairo (1.10.0 x86-mingw32)

columnize (0.3.4)

gdk_pixbuf2 (1.0.0 x86-mingw32)

glib2 (1.0.0 x86-mingw32)

green_shoes (0.263.0)

gtk2 (1.0.0 x86-mingw32)

linecache (0.46)

pango (1.0.0 x86-mingw32)

pkg-config (1.1.2)

rake (0.9.2)

rbx-require-relative (0.0.5)

ruby-debug (0.10.4)

ruby-debug-base (0.10.5.jb2 mswin32, 0.10.4)

ruby-debug-ide (0.4.17.beta5)

rubygems-update (1.8.7)

Now if I try to run a "hello world" like...

require 'green_shoes'

Shoes.app( :width => 250, :height => 250 ) do

  para 'Hello, world!'

end

...RM tells me that it can't locate the gem:

C:\Ruby187\bin\ruby.exe -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) C:/Users/an/RubymineProjects/untitled/test

C:/Users/an/RubymineProjects/untitled/test:1:in `require': no such file to load -- green_shoes (LoadError)

from C:/Users/an/RubymineProjects/untitled/test:1

from -e:1:in `load'

from -e:1


Process finished with exit code 1

So I thought to hint RM a bit and added _all_ subdirectories that there are for this gem to the projects/settings/loadpath section:

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\lib

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\LICENSE

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\samples

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\snapshots

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\static

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\VERSION

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\lib\ext

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\lib\plugins

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\lib\shoes

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\lib\ext\bloops

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\lib\ext\chipmunk

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\lib\ext\highlighter

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\lib\ext\hpricot

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\lib\ext\projector

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\lib\ext\bloops\songs

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\lib\ext\highlighter\lang

C:\Ruby187\lib\ruby\gems\1.8\gems\green_shoes-0.263.0\samples\potato_chopping

-Well, same result -what goes wrong here? How do I have to tell RM that it recognizes the green_shoes lib??

1 comment
Comment actions Permalink

Solved it myself (tnx @Steve Klabnik for pointing this one out!): green_shoes requires ruby 1.9.2, so I switched over from 1.8.7 to 1.9.2 and everything is fine!

0

Please sign in to leave a comment.