Rubymine 3.2.2 freezes during file edit (Ubuntu 11.04 x64)

Hi,

I was searching for a good RoR-IDE and tried RubyMine - and I really like it!

The problem is that it often freezes during file edits. As the CPU load increases during these phases I guess that it searches for autocomplete options or something like this. Disk usage is sometimes increased as well.
The freezes happen not only directly in variable names but also e.g. in strings or when I select something in the code.

My installed java-version should be ok, I have for 4GB RAM installed (which should be enough even for x64) and a 4x2,83GHz CPU.

Is there a way to avoid these freezes? If you need any more information, I'll add them.

Thanks in advance!

PS: And for some reason this question won't stay in the "linux" tag-group

----------------------------------------------------
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
----------------------------------------------------

3 comments
Comment actions Permalink

Hi Stefan

My recommendation would be to try RubyMine 3.1.1 instead as that is far more stable and not prone to the freezes you and many here are experiencing.

HTH

0
Comment actions Permalink

Hello guys, have you tried Invalidating caches? This should help.
If you are experiencing problem with constantly scanning gem requirements, please comment corresponding issue: http://youtrack.jetbrains.net/issue/RUBY-8977
We've already managed to reproduce it and fix will be available in a couple of days.


Regards,
Oleg

0
Comment actions Permalink

I'm using 3.1.1 now, seems to be twice as fast as 3.2.x

0

Please sign in to leave a comment.