3.2.2 Right Click not working


Ubuntu. I downloaded Rubymine 3.2.2 and the right click doesn't work. My laptop also nearly freezes and rubymine does freeze for a few moments. I got 3.2.1 back out of the trash can and it works fine. BTW, I can't double click on a file to bring it up, have to click jump to source. Same for both versions.



I also use Ubuntu (11.04) and had numerous problems (similar to what you describe) with the first 3.2.2 build. I then downloaded a newer version and all of the problems went away. Hopefully that is your problem as well. In Help > About make sure you have #107.446, dated July 22nd.

Hope this helps,


I tried the latest version (446 build on Ubuntu 11.04) and after few minutes, I get the same annoying CPU/gem scanning problem


I am seeing a similar problem with rubymine 3.2.2 on windows 7. Right click hangs the application for ~5-6 seconds


I had the same problem. Invalidating the cache seems to fix it.

  1. Go to menu File -> Invalidate Caches
  2. Click "Invalidate and restart"

I tried invalidating the cache and it had no effect. The problem seems to have gotten worse over time because now the main menus and the debugger also regularly freeze for 5-8 seconds. I have reverted to rubymine 3.1.1 as 3.2.2 has become unusable.


3.2.2 441 is bad-bad-bad, just downloaded 446.
It started with complete freeze for 30 secs.
Invalidate Cache --- good -- working fast,right-click -- ok.
After 20 minuts -- again often stoppages for 3-20 secs.

i7-2600, 8G, SSD,
Fedora 15, RM 107.446, full inspection

What JVM options do you suggest for i7-8G ?

Myzhiki, how can I help to debug?



Hello A V,

The best way you can help us in this case is to capture CPU and memory snapshot after you face with this problems again.
Instructions are here: http://devnet.jetbrains.net/docs/DOC-1144
Also please note, that we have global changes scheduled for RubyMine 4.0 which are supposed to fix the problem at all.



Hi Oleg,

That's great news! But it begs the question: When is 4.0 due to be released? :)

-- Larry


RubyMine 4 is scheduled approximately to Q4 of 2011.



You have to disable TouchPad and connect your mouse I fixed that in this way


I found a solution for my use case. It's not Intellij-related but I'm pasting it here in case it helps anyone:

  • If you are running Steermouse
  • And you have setup a "Chord" (multi mouse button command) that uses the right click

....then the right click does not work (tested on RubyMine 2019.3.4 and Webstorm 2019.3.4). Disabling the chord that uses the right click makes the button behave properly again in all jetbrains products.


Thank you so much Angelos Chaidas ! This is a lifesaver for me. It has been bothering me for weeks not being able to right click.


Angelos Chaidas fix worked for me too except that I was running the app "Smooze" that also configures Input Devices like Steermouse. I had a gesture configured with the right mouse button that needed to be removed. What was interesting is that the trackpad right click was registered by IntelliJ but the external mouse not.


Please sign in to leave a comment.