Local History Gone

Hi,

I'm using v. 3.2.1. I just fired up the "Local History" for a file that I made several changes to yesterday and today. When I first did it, it showed the list of all of the changes in the left-window. The problem was that whenever I clicked on a version it rerported that there were "No differences" - even though there I knew there were. The time also said "2 minutes ago" no matter which version I clicked on - which could explain why it kept reporting "No differences".

So I tried looking at other files that I have been working on all day, and now the "Local History" does't even work! The window fires up, but the left-window simply says "History is empty" no matter what file I look at. I have re-booted the IDE a few times and that didn't help.

Has anyone else seen this problem? (Which, by the way, really, really sucks.)

-- Larry

P.S. I just made a change to a file and it does show the "Local History" for the change I just made, but I have tried this on several files that I have been working on all day long and there is no "Local History" for any of them. To me, this is a feature that *must* be able to be counted on. It is simply unacceptable to loose the "Local History" for a bunch of files.

3 comments
Comment actions Permalink

Hello Larry,

Is this behaviour reproducible? Could you please file an issue with steps to reproduce at http://youtrack.jetbrains.net/issues/RUBY?
And please attach log file after yet another problem. Here is the instruction on log file: http://devnet.jetbrains.net/docs/DOC-1153

Regards,
Oleg

0
Comment actions Permalink

Hi Oleg,

It's working now, so there's really nothing I (or you) can do about it for now**.

I'll let you know if it happens again, and thanks for the follow-up.

-- Larry

** I suppose I could stop drinking while coding, but that would take all the fun out of it!;)

0

Please sign in to leave a comment.