RSpec and Cucumber are not working in 3.2 RC


I have installed 3.2 RC and when I try to run rspec or cucumber I got error message saying:

RSpec support is disabled because it is not acitvated


Cucumber support is disabled because 'cucumber' gem or Cucumber Rails plugin is missing'

Both cucumber and rspec gems are installed




same issue on ubuntu 11.04, rubymine 3.2, rvm, rspec 2.6.0, ruby 1.9.2


+1 here

I even downloaded romans sample app, which isn't working either.



Same here. 3.2.1.

Installed on OSX.  Using RVM.

ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-darwin10.7.0]

cucumber (1.0.0, 0.10.0)

No luck after installed cucumber via RM:

2011-07-08 11:20:57,110 [ 523248]   INFO - lugins.ruby.gem.GemInstallUtil - Installed gem: cucumber (1.0.0)

Also - cucumber (1.0.0., 0.10.0) correctly is displayed in the Ruby SDK and Gems project settings.

One odd thing: there's three SDK's.  All three are named the same, except the last two have "[global]" suffixed.  The [global] SDK's only have rake installed gem.  Removing the [global] and rerunning does not fix the issue.

Also - I can choose the cucumber version in my Run configuration, default/1.0.0/0.10.0.  No joy.


LOL solution:

In Run/Debug Configurations' Ruby SDK radio-button area manually set "Use other SDK and 'cucumber' gem: ... then select your SDK.

Some kind of bug in the "Use project SDK: RVM: ruby-1.8.7-p352"...!

:p  Not my fault!!!


this solution is not working for me. does it have to be 1.8.*? I only have 1.9.2 installed right now.


Dunno - I only have 1.8 :)


to answer my own question just installed 1.8.7 with rvm and i still have the same issue.  are using a non-rvm ruby?


another work around, of course, is to use a rake task


Good to try it though.

I'm using RVM  /Users/nick/.rvm/gems/ruby-1.8.7-p352/

There's no indicator of the failure cause, to my eyes, in the RubyMine log file.Screen shot 2011-07-08 at 1.22.19 PM.png


That helped me too, if I select Use other SDK... and select the same SDK then it works


Do you use bundler? Could you attach a screenshot of "Libraries" node in Project View? Bundler & Gem file is highly desired for RubyMine 3.2 because we dropped our "attach" gems dialog and now RubyMine considers gems mentioned in gemfile. There is support for rails 2.3.x and plain ruby applications. In rails 2.3.x rubymine parses environment rb in plain ruby project - analyzes "gem 'foo'" commands. But bundler+gemfile works more stable and predictable.


No, I am not using bundler

But when I tried with bundler and created a gemfile and added rspec then it worked for me


My workaround (radio-button select the SDK) doesn't improve / fix how the right-click Action menu fails to execute the currently focused file, btw.

Are there more logs I can provide?  Should this be logged in a bug database?


Please sign in to leave a comment.