Debugger issue on Windows 7 (64bit)

I am unable to run the debugger on Windows 7(64bit). I am using Rails 2.3.9 and Ruby 1.8.7.

When ever I tried to run the debugger, I get the following error:



Cannot connect to the debugged process at port 51820 in 10s:

Dumping and destroying process, when the debuggee process is running. You might try to increase the timeout. Killing...

Error Output:
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require': no such file to load -- require_relative (LoadError)
 from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
 from C:/Ruby187/lib/ruby/gems/1.8/gems/linecache-0.45/lib/linecache.rb:66
 from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `gem_original_require'
 from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `require'
 from C:/Ruby187/lib/ruby/gems/1.8/gems/ruby-debug-base-0.10.4/lib/ruby-debug-base.rb:3
 from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
 from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
 from C:/Ruby187/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.17.beta5/lib/ruby-debug-ide.rb:5
 from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
 from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
 from C:/Ruby187/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.17.beta5/bin/rdebug-ide:7
 from -e:1:in `load'
 from -e:1

Please try increasing timeout in Settings | Debugger | Ruby | Debug connection timeout

2 comments
Comment actions Permalink

I am on RubyMin 3.1.1

0
Comment actions Permalink

The issue is due to the latest version of

linecache
gem. I had to revert to an older version(
0.43
) to get around the issue.

I did the following to get fix the issue:

gem uninstall ruby-debug-ide ruby-debug-base linecache
gem install ruby-debug-ide


Re-install

ruby-debug-base
gem
gem uninstall ruby-debug-base
gem install  ruby-debug-base --platform mswin32


Re-install

linecache
gem

gem uninstall linecache
gem install  linecache  -v 0.43
0

Please sign in to leave a comment.