run individual spec option missing

Since upgrading to 3.1.1rc2, I can't run individual specs.   The context Run menu item seems to be gone.  This happening for anyone else?

14 comments
Comment actions Permalink

No problem here with 3.1.1 rc2, right click -> run xxx.spec

0
Comment actions Permalink

Ok, I created a new rails project and it works.  So it's a problem with my project.   I tried deleting every config file I know of and restarting, but it didn't help.  Also, for some reason, when I click on the Models directory, I get a little loading icon which never finishes and the directory doesn't expand.  Any idea what that's about?  

How can I totally blow away all Rubymine settings?   I'm on Snow Leopard if that helps.

0
Comment actions Permalink

I'm having the same issue I believe. The Run... command simply isn't popping-up the Run dialog, same with Debug... Keyboard shortcuts aren't working either.

On a Mac, your RubyMine prefs should be in ~/Library/Preferences/RubyMine31. I haven't tried blowing that away yet (I just downgraded to 3.1.1 RC), but let us know if it helps.

0
Comment actions Permalink

Hi guys,

Please check that "rspec" gem as "attached" in "RubyMine | File | Settings | Ruby Sdk And Gems" dialog. Also check that your *.spec file requires "rspec" (e.g. requires 'spec_helper' script which requires 'rspec' or 'rspec/rails' script)

0
Comment actions Permalink

The rspec and rspec-rails gems are attached, and I'm calling require 'rspec/rails' in spec_helper.rb.  
I stopped RubyMine,  blew away the preferences, cache, and properties directories, as well as my projects .idea folder, and restarted.  Still no love ;(

Could this be related to whatever is causing my Models folder to not load?  fwiw, I have an odd db setup as I'm making use of postgres's table inheritance features.  Both of these problems started when I upgraded from RC1 to RC2.  I'm running rails 3.0.5, ruby 1.9.2-preview3, and rspec 2.5.0

Thanks!

0
Comment actions Permalink

mixtli wrote:

The rspec and rspec-rails gems are attached, and I'm calling require 'rspec/rails' in spec_helper.rb.

Could you attach a screenshot of Settings | Ruby Sdk and Gems manager dialog ?
Also please attach diagnostic info from Tools | Show Gem environment dialog.

Could this be related to whatever is causing my Models folder to not load?


What do you mean? It isn't visible in 'Rails Project View' tree? Could you explain..

fwiw, I have an odd db setup as I'm making use of postgres's table inheritance features.  Both of these problems started when I upgraded from RC1 to RC2.  I'm running rails 3.0.5, ruby 1.9.2-preview3, and rspec 2.5.0


You can revert to RC1 if no luck but for us better to investigate the problem at first
0
Comment actions Permalink

Screenshots attached.

The third screenshot is what happens when I try to open the Models folder.   It just says "loading.." forever.   Also noticed that when I run "Show Model Dependency Diagram", it doesn't generate a diagram.

Reverting back to rc1 is not really so good either as I upgraded due to the rspec/spork integration issue ;(

I can live without the Model folder.. I can still get to the files with cmd-shift-n, or with the Project view.   I noticed that I can run all specs in a directory (for example, specs/controllers), but I cannot run an individual file, let alone an individual spec.   Last screenshot shows the context menu when I try to run an individual spec.  No "Run" option.



Attachment(s):
Screen shot 2011-03-29 at 9.52.16 PM.png
Screen shot 2011-03-29 at 9.45.07 PM.png
Screen shot 2011-03-29 at 9.43.17 PM.png
Screen shot 2011-03-29 at 9.39.20 PM.png
0
Comment actions Permalink

Ok, I got it working.  When I blew away the prefs the first time, I neglected to blow away prefs for a previous version.  After blowing those away too, everything works flawlessly!   My models are now loading again too.   Thanks for the help.

This latest version seems pretty awesome.  Nice job, guys!

0
Comment actions Permalink

I've got the same behavior with individual spec files in RM3.1.1RC2. Context menu items are gone.

Invalidated caches, removed the ~/Library/Preferences/RubyMine31 and even the hidden .idea folder within the app folder. Doesn't make no difference.

The context menu works for the spec directory and all its subdirectories (folders), but not for files.

Hubert
MacOSX10.6.7/Ruby 1.8.7/Rails 3.0.5

0
Comment actions Permalink

I've got the same behavior with individual spec files in RM3.1.1RC2. Context menu items are gone.

Invalidated caches, removed the ~/Library/Preferences/RubyMine31 and even the hidden .idea folder within the app folder. Doesn't make no difference.

The context menu works for the spec directory and all its subdirectories (folders), but not for files.

Is rspec-rails gem attached in "Ruby SDK and Gems Manager dialog" ? Does your *_spec.rb files require spec_helper.rb which requires 'rspec/rails' or 'rspec' scripts?. Please attach idea.log as explained at http://devnet.jetbrains.net/docs/DOC-1153

0
Comment actions Permalink

After blowing those away too, everything works flawlessly!   My models are now loading again too.

Something strange..

0
Comment actions Permalink

Yes, the gems are installed and attached:

rspec 2.5.0
rspec_rails 2.5.0

The spec helper file includes (within a spor prefork block):

require File.expand_path("../../config/environment", __FILE__)
ENV["RAILS_ENV"] ||= 'test'
require 'rspec/rails'
....

And it is required at the top of every file:
require 'spec_helper'

I've attached the two variants of the context menu (folder and file) in the project view and another one of the console, where I cannot re-run the failing specs.

Hubert



Attachment(s):
Bildschirmfoto 2011-03-31 um 22.13.10.png
Bildschirmfoto 2011-03-31 um 22.11.27.png
Bildschirmfoto 2011-03-31 um 22.11.04.png
idea.log.zip
0
Comment actions Permalink

Thank you for logs. According to log exception occurs while RubyMine tries to create rspec run configuration. Issue is already fixed and will be available in next 3.1.1 public build. See http://youtrack.jetbrains.net/issue/RUBY-8133

0
Comment actions Permalink

Thanks, Roman!

Hubert

0

Please sign in to leave a comment.