rake cucumber:wip runs default cucumber profile instead of @wip profile

I have a single cucumber scenario tagged with @wip. From the command line, at the root of my project I can type:

rake cucumber:wip

And the scenario runs.

From Rubymine if I run:

Tooks > Rake tasks > cucumber > wip (or the keyboard equivelant)

The default cucumber profile gets run.

Thanks in advance if you can help me fix this!

-MIke

3 comments
Comment actions Permalink

We attaches our GUI tests results reporter using CUCUMBER_OPTS env variable and seems it also overrides profile value. As a workaround
1. Lunch cucumber:wip rake task. RubyMine will automatically generate "cucumber:wip" temporary rake run configuration.
2. Save temporary run configuration - Main Menu | Run | Edit Configurations | Rake | cucumber:wip. Choose "save" in context menu
Screen shot 2011-03-28 at 6.58.36 PM.png
3. Set CUCUMBER_OPTS env variable with value "--profile wip"
Screen shot 2011-03-28 at 6.59.58 PM.png
4. apply settings and rerun saved "cucumber:wip"
Screen shot 2011-03-28 at 7.01.01 PM.png

0
Comment actions Permalink

Wonderful! Thanks so much for your response. That's one of the things I most often have to leave the Rubymine UI for... now I almost never have to change contexts to develop my rails app. Thanks again. -Mike

Message was edited by Mike Bannister because his grammar was broken.

0
Comment actions Permalink

Ok, good. Develop with pleasure!

0

Please sign in to leave a comment.