ruby plugin ( not mine ) sdk configuration problem

This seems like a common problem but it feels confused by "Ruby Mine".
I am just trying to use IDEA and the ruby plugin but can't figure how and where
to tell IDEA to find the SDK



Attachment(s):
ruby.png
3 comments
Comment actions Permalink

Press yellow '+' button and choose Ruby/JRuby sdk type

0
Comment actions Permalink

Roman

I read your reply which requested press yellow + and chose Ruby/JRuby

I did this on the Project (Structure) Template page.

Please look at the attached file, then I tried "Run" but still indicates no sdk.

Am I trying to solve this in the wrong place ?


Attachment(s):
ruby_plus_button.png
0
Comment actions Permalink

Am I trying to solve this in the wrong place ?

Probably Ruby SDK isn't set in module settings. See "Modules" section in Project Settings (section is shown on your screenshot). Several ways are possible:

  1. Module type is Ruby (not a java module)
    1. module sdk is inherited project SDK and some Ruby SDK is set as project SDK
    2. module sdk is some Ruby SDK
  2. Java module type with JRuby facet. JRuby SDK should be set in facet settings.
0

Please sign in to leave a comment.