Odd editor autocomplete

With v3.1, I noticed some less-smooth editor behavior. First off, it seemed to have dropped the auto-surround -- so that seleecting text and typing a double quote ended up deleting the text! I went into settings and fixed it...

But I digress... Now I have more weirdness that I do not recall from earlier version.

I was simply editing the beginnings of an RSpec file:
initial rspec.png
For some odd reason, the describe's object gets highlighted, even though all I did was put my cursor at the end of <<EO -- poised to type CSV! (Get it>? End of the CSV multi-line test string?)

So, once I type "C" this happens:
after typing C.png

and as I finish typing CSV, my file is hosed:
after typing CSV.png

Comment actions Permalink

Please try 3.1.1: http://confluence.jetbrains.net/display/RUBYDEV/RubyMine+EAP.
Also try File | Invalidate Caches.
If the issue remains, file a bug at http://youtrack.jetbrains.net/issues/RUBY with the sample code attached and the steps to reproduce.

Comment actions Permalink

So I tried the invalidate caches... it seemed to work. For a while. But the error creeps back in, and is seemingly impervious to cache clearing.

I am finding myself anticipating the delay of the editor -- a very uncharacteristic thing to do with RubyMine. And the Activity Monitor shows RubyMine pegging 100% or more...

So now I am trying the EAP... I'll keep you posted.

Comment actions Permalink

I did not seem to fare much better with the EAP. Now I am trying to shitcan 3.1 from my system... Going back to 3.01.

Now 3.01 won't even recognize that right-click on an rspec file should offer up the Run Spec action :-(  WTH.

I am growing old watching RubyMine re-attach the same damn gems over and over,  re-index, and invalidating caches, and switching back and forth between versions to try and get my work done :-(

This is *not* the JetBrains way...

Guess I'll have to use my TextMate for a while :-(


Please sign in to leave a comment.