RM 3.1 issue with git

Hello,

With RM 3.1i have an issue with git. Opening a existing project,when I modify a file, it is flaggled as "deleted" in RM (the name is greyed) and when I commit it doesn't appear in the list to be committed.
I don't thing this is a problem with git because:
- the command line git status give me the right information on file modified
- re-openning the project with RM 3.0 gives me the right information (the file name is blue)

Thanks
Nicolas

10 comments
Comment actions Permalink

Hello Nicolas,

1. You modify a file, it is flagged as "deleted", but calling "git status" from the command line tells that the file is modified. Right? Could you please make a screenshot, where I could see both IDEA's Changes View (with the file marked as deleted) and command line "git status" output?

2. If you press the "Refresh" button in the Changes View, does the file status change to the correct one?

0
Comment actions Permalink

Hello here are the copy of both RM and terminal
RM3.1-1.png
Terminal.png
If by "refresh" you mean "synchronize" then it has no effect on this issue.

Nicolas

0
Comment actions Permalink

It doesn't look like a deleted file, more like ignored file.

Please check in Settings -> Version Control -> Ignored Files if your file matches with one of ignore patterns.

Note that RubyMine has Changes Tool Window. All your changes are displayed there, like in git status. And there is a Refresh button.
See the screenshot:
changes_view.jpg

0
Comment actions Permalink

You are right this are ignored files.
I do not use this setting (I setup the ignored files with the git command line) and I  looked into the   Settings -> Version Control -> Ignored Files and apparently they are flagged as ignored but the strange things is that if I open the same project with RM3.0, I see the same configuration for the ignored file but my modified file is flagged blue as modify.

Nicolas

0
Comment actions Permalink

So, the solution is removing your files from the list of ignored.

Unfortunately, currently IDEA's ignored files and .gitignore are not consistent (see http://youtrack.jetbrains.net/issue/IDEA-60354 ), so to really ignore files you have to add them to .gitignore. On the other hand, the file won't appear in the Changes View and the commit dialog if it is in IDEA's ignored files.

There was a huge amount of changes between RM3.0 and 3.1, so this different behavior is fine.

0
Comment actions Permalink

Hello,

if I understand correctly I must setup the ignored files both with git and RM? If yes then I will stay with RM 3.0 until this is fixed.

Nicolas

0
Comment actions Permalink

Nope, you have to specify files to ignore only in .gitignore.

I would highly recommend upgrading to 3.1 since there are a lot of new feature, performance was also increased.

0
Comment actions Permalink

Hello Kirill,

This is not what is written in the defect you mentionned earlier in this discussion where it is stated that any modifciation should be reflected in both RM and .gitignore.
And my gitignore is fine, but it doesn't make RM3.1 working as is.

0
Comment actions Permalink

Nicolas,

it seems that there is a sort of misunderstanding here.
Let me try to arrange the facts.

1. Your original problem (not able to commit a file, file status is not correct) is because you've added the file to IDEA's list of ignored files. Just remove the file from IDEA's ignore list.

2. If you add a file to .gitignore, it will be ignored by Git and by IDEA.

2.1. The issue I referred is about the following: if I add a pattern to .gitignore, I can't see this pattern in IDEA's ignored files and the file status is black (not-modified) instead of dark-gold (ignored) (but of course the file is ignored and won't show as changed); if I add a pattern to IDEA's ignored file, it is not added to .gitignore.

Hope this helps.

0
Comment actions Permalink

Ok, thanks for the clarification. I have done what you said and now it is working.

Thanks for your patience
Nicolas

0

Please sign in to leave a comment.