Rubymine and Imagemagick not playing well?

I just installed Rubymine, and Imagemagick through the terminal for use with Rails Papercilp.

For some reason if I run the Rails server through terminal everything works, BUT if I run the rails server through Rubymine, it tells me Imagemagick is missing!!

Anyone have any thoughts? I've been trying to figure out this config issue for hours now. Is there something quirky about Rubymine terminal and my regular terminal? Is there something different about the Rubymine server vs my standard "rails s" terminal server?

By the way, I'm using MacOSX Snow Leopard.

5 comments
Comment actions Permalink

Are you sure that you use the same ruby interpreter (or RVM gemset) in terminal and your RubyMine project? Please check which interpreter is used in project on "RubyMine | File | Settings | Ruby SDK and Gems" tab.

0
Comment actions Permalink

Yup I'm using the same ruby version.
I'm beginning to suspect it has something to do with my environment variables. I don't think rubymine is picking up my environment variables for some reason??

The problem isn't with the gems, but the imagemagick library. The Paperclip gem runs fine, but when I run it through rubymine paperclip cannot find imagemagick.     

0
Comment actions Permalink

OK after 7 hours of trying to figure things out i realized that rubymine doesn't properly inherit environment variables.

why doesn't it? can the devs explain why?

to fix it i had to manually move these variables into my environment.plist, and set some of them manually through rubymine.

anyway i hope people who use rubymine in the future realize this!

0
Comment actions Permalink

OK after 7 hours of trying to figure things out i realized that rubymine doesn't properly inherit environment variables.

why doesn't it? can the devs explain why?

Seems better to ask Steve Jobs or Mac OS dev team. It's limitation of MacOS please see javascript:;. If you launch RubyMine from Terminal.app environment will be ok without environment.plist.

0
Comment actions Permalink

damn, you guys already had a tutorial for this?
you should put this info, or a link to it on the main page somewhere after you download!

thanks tho!

0

Please sign in to leave a comment.