Does RubyMine have a built in rails shell that you can type in and execute rails script or rake tasks on the fly (not the IRB Console)?

I come from RadRails which has a shell that I can type any rails/rake commands in (scaffold ..., whatever). Is there something like that in RubyMine and if so where is it in the menus?

Thanks in advance.

Mark

7 comments

Hello Mark,

RubyMine doesn't have a built-in shell, but it has a specific action for
executing Rake commands (Tools | Run Rake Task...) and another action for
running generators.

I come from RadRails which has a shell that I can type any rails/rake
commands in (scaffold ..., whatever). Is there something like that in
RubyMine and if so where is it in the menus?


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Thanks would be a great feature and probably pretty simple to implement.

The reason I am asking is that I tried to run a rake task in a plugin in the project in the Rake Task menu item and it did not find it as part of its lookup and so I could not run it.

Mark

0

Hello Mark,

Most likely some error occured while RubyMine was trying to get the full list of rake tasks available.
Please try running Tools | Rake Tasks | Reload Rake Tasks. Do you see any errors in execution console?

Regards,
Oleg

0

@Oleg Thanks for the thought. Took me a while to get back to what I was doing with RubyMine. Anyhow, trying out the rails 3 upgrade plugin in a 2.3.5 rails app using RubyMines 2.5 rails 3 prerelease version. When I reload the rake tasks I get the message:

[rake --tasks] rake aborted!
no such file to load -- initializer
C:/ruby-1.8.7/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
C:/ruby-1.8.7/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
D:/r3p/rubyamf_testing/config/boot.rb:55:in `load_initializer'
D:/r3p/rubyamf_testing/config/boot.rb:38:in `run'
D:/r3p/rubyamf_testing/config/boot.rb:11:in `boot!'
D:/r3p/rubyamf_testing/config/boot.rb:110
C:/ruby-1.8.7/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
C:/ruby-1.8.7/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
D:/r3p/rubyamf_testing/Rakefile:4
C:/ruby-1.8.7/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2383:in `load'
C:/ruby-1.8.7/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2383:in `raw_load_rakefile'
C:/ruby-1.8.7/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2017:in `load_rakefile'
C:/ruby-1.8.7/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
C:/ruby-1.8.7/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2016:in `load_rakefile'
C:/ruby-1.8.7/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2000:in `run'
C:/ruby-1.8.7/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
C:/ruby-1.8.7/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
C:/ruby-1.8.7/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
C:/ruby-1.8.7/bin/rake:19:in `load'
C:/ruby-1.8.7/bin/rake:19

Took out all my plugins and tried to reload rake tasks and still got it, so it was not the plugins, but something with version incompatibility I guess. I have noticed someone post that this happens with rake and rails 3 with rails 2 versions, but they gave no solutions.

Any ideas?

Mark

0

@Dmitry

Thanks. Have been trying RubyMine and like it. Very comprehensive, but really miss the Rails shell in RadRails. Have you a reason you have not included one. Seems you have everything there to pop open an console and run script vs in a little popup. Just wondering.

Mark

0

I've am relaitively new to RubyMine having come from TextMate.

I have to second that - RubyMine needs a command line built into the editor workflow. I love the JetBrains text editor but hate the clumsy nature of the IDE.

The usage of IDE wizards, while helpful, is somewhat hindering and clumby. I feel RubyMine is going in the wrong direction as far as remain to true to spirit of rails development - concision, agility, convention over configuration (or wizzrds), and less mice and hamsters running on wheels. I think Aptana is going in the right direction in embracing a more keyboard friendly workflow. RubyMine (and IntelliJ) would benfit from having a robust command line built-into the IDE and workflow at it's core, not only to execute ad-hoc Rails/Rake commands, but to manipulate the project in otherways such as a an extendable shell syntax tied into the platform plugin systems, or even manipulate RubyMine/IntelliJ projects in headless mode. I am noticing the GEMSET manager, Ruby environment, and GIT workflow seem are bit akward as well. I have to navigate through a series of menus that bare little resemblence to the command line workflow.

some suggestion for the IntelliJ Platform Team

  • built in shell, built in all-keyboard accessible workflow
  • built in shell offers syntax highlighting, formatting, customizability
  • better SSH support and SSH support into shell
  • built in shell offers syntax completion of commands and code
  • shell environment is extendable by plugins and accessible to plugins
  • shell environment can manipulate the .idea project context (even in headless mode)
  • get rid of the workflow clutter, in paritcular with version control. I don't need all those menu options if my project only uses GIT
  • Build RVM or sutiable options directly into the IDE shell system to create the notion of execution and development sandbox environments
  • visual dependecy and repository management (which is where we need visualization)
  • better GIT integration and repository management built into the IDE
  • wizzards and dialogs augment available command line workflow.


If I worked at JetBrains...

Cheers,
Rafael

0

Rafael,

Thank you for a feeback, I hope we will implement it in 4.0. Please track issue http://youtrack.jetbrains.net/issue/RUBY-4628

0

Please sign in to leave a comment.