Debugger exits when requiring native .so (Ruby 1.9.2)

Hi all,

I tried debugging a Ruby (1.9.2p136) script that has

require 'openssl'

as its very first line.

I can break at that line, step into it, but as soon as I try to step over

require 'openssl.so'

the debugger disconnects and won't stop at any other breakpoint.

The console doesn't show any errors, except that the last line says:

Process finished with exit code 134

I installed the debug gems that come bundled with RubyMine (EAP
102.217), so I'm using the debug-base19 gem modifie
d by JetBrains and the debug-ide gem and all the others that come
preinstalled.

My Ruby installation is built with no debug symbols, it's the vanilla
configure/make/make install process. Would it help
to enable debug flags?

Another question: RM uses debug-ide instead of debug-ide19, can I
somehow force it to use debug-ide19 if I would install it?

PS: I also checked the option for "Disable global variables evaluation"
in Settings to no effect.


Thanks for any help,
Hans

2 comments
Comment actions Permalink

Please try updating to the 3.1 Beta it will install updated ruby-debug-ide gem and see if the problem persists. In case it does, please enable verbose debug output (Settings | Debugger | Ruby) and file an issue with full output attached.

ruby-debug-ide19 gem is no longer needed, it have been merged into ruby-debug-ide to support both 1.8 and 1.9 rubies. Moreover, ruby-debug-ide19 has several critical bugs that cause segmentation fault during debug.

0
Comment actions Permalink

Hi, thanks for your help! I finally found out what caused the trouble: The openssl.so that I was using was linked to a custom 1.0.0c version, whereas the ruby debug gem was linked to the default installation. That caused the sudden disconnect. Once I built openssl.so against the default installation, the debugger worked smoothly.

0

Please sign in to leave a comment.