No font antialiasing in windows?

Hello,

I'm jus trialing rubymine 3 in windows. Is it normal for the fonts in windows to have no antialiasing? It looks horrible. Is there a work around?

JDK 1.6.0_21

Thanks.

6 comments
Comment actions Permalink

Please check "RubyMine | FIle | Settings | Editor | Appearance", "Use antialiased font" option.

0
Comment actions Permalink

It is very much checked already!

0
Comment actions Permalink

Hello Troy,

Do you have antialiasing enabled in your Windows desktop settings?

It is very much checked already!


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I was unaware there is antialias settings in Windows 7? Are you referring to cleartype? This is enabled. Fonts still look horrible. :(

0
Comment actions Permalink

Good point -- under WinXP I played with performance and disabled antialiasing for each application.
Yeps -- web sites, RM and all the rest became very ugly. I have returned the setting and all is fine.
Never experienced any troubles with fonts on my PC nor my colegues (all are WinXP Pro, no Win7)

0
Comment actions Permalink

The settings under "Editor | Appearance" and "Editor | Colors & Fonts | Font" only apply to the editor window.

If you're not liking the font used in the rest of RubyMine (menus, tabs controls, etc.), then try playing around with the 'top-level' "Appearance" setting panel.

Changing the "Look and feel" theme made RM look better for me - it defaulted to "Alloy.IDEA theme"; I chose the "Windows"  theme.

The "Override default fonts by (not recommended):" setting will also let you choose a more likeable font for the rest of the RubyMine UI, but I'm not sure why it says it's not recommended.

Note that the "Apply" button on this panel doesn't alway enable after you change a setting.  It seems like you have to tab or click away from teh item you change to get the "Apply" button to enable sometimes.

0

Please sign in to leave a comment.