How do I configure my branches to "compare with branch"?

I just cut a new SVN branch of my code. Of course that was followed by some changes that need to be applied to both the new branch and trunk. I made the changes on the new branch, and tried to merge to trunk using the right-click "compare with branch..." option but it didn't work. I get the dialog asking me to compare with trunk, branches, or tags and I click branches. I see my branches. I click the new branch that I want to merge code from. Soon thereafter I get an error saying "svn: URL 'svn+ssh://...../branches/2.0' refers to a directory."

I tried to use the "configure branches" option but that doesn't let me make changes (The "OK" button is always disabled). Is there something I should change to make this work or is this a bug?

I am able to integrate from the new branch to trunk, but I prefer to compare changes and bring them in manually.

Thanks!

5 comments
Comment actions Permalink

Now I'm on RubyMine 3.0 and this problem is still haunting me. I thought it might help to describe the layout of my SVN repo as it's not completely the norm:

svn/
     |_tags/
     |_trunk/
        |_project1/
        |_project2/
        |_common/
      |_branches/
        |_2.0.1
          |_project1/
          |_project2/
          |_common/
        |_2.0
          |_project1/
          |_project2/
          |_common/


Quite often I want to compare a file in svn/branches/2.0.1/project1 with the trunk version of the file at svn/trunk/project1, but RM won't let me because of the problem I described originally. Also, note that when I go to the configure branches the dialog it says "Trunk location must be under repository root". Since I can't change the "Trunk location:" value (the ellipses next to the field don't work, and if I change it manually I can't hit the 'OK' button because it's always disabled) I've tried updating my misc.xml file manually. I've tried setting trunkUrl to svn/, trunk/, etc. but no luck.

Given the repo structure above, what should my misc.xml values be to get this to work?

0
Comment actions Permalink

Hello Christopher,

for project1, you should have:

trunk = svn/_trunk/_project1
branches=svn/_branches/_2.0.1
and
svn/_branches/_2.0

Error text appears, if your trunk url is shorter than "repository_url/"
obviously, it should be longer than just repository url

0
Comment actions Permalink

Thanks for the reply. Please see the attached screenshot. Those are the values RM fills in for me based on what it knows about my SVN repo. I am unable to configure my trunk location the way you suggest. The ellipses at the end of the dialogue are always greyed out, and when I type /_project1 at the end of the trunk location URL the OK button remains greyed out. No matter what change I make, I can never save the changes.



Attachment(s):
configure_branches.png
0
Comment actions Permalink

And please also attach a screen with your working copy data?
(I want to see the url)

that in Changes | Local | Subversion Working Copies information

0
Comment actions Permalink

Sorry, Irina, but I don't understand. What exactly do you want me to take a screenshot of? I'm not sure what I should do to get you the URL you want to see.

Thanks!

0

Please sign in to leave a comment.