RubyMine 3 RC2 won't respect default runtime configurations

Our Ruby projects uses bundler to setup all required gems and version for production.
On our local developer environments we use rubymine for debugging.
Thus we installed all the necessary gems (debug-base and debug-ide) only on our local machines and did NOT put them in the Gemfile.
For the defautl runtime configuration we therefore set not to use bundler for running rspec files (edit configurations -> edit defaults -> rspec -> tab bundler; removed checkbox "run the script in context of the bundle")

When I try to run a single rspec test in debug mode, RubyMine always prompts me to update the current installed ruby-debug and ruby-debug-ide gem, because they are outdated.
Clicking YES for both gems fails with an error.
The test will also not execute with an error: Can't connect to debugger process.

Checking the configuration for the selecte test, it has the above mentioned checkbox selected.
After unselecting it again, all will run fine and I can debug my test.

Is this a potential bug?

Hope I could explain the setup good enough. Please let me know if you need more details.

Versions in use:
RubyMine: 3.0 RC 2
bundler: 1.0
rspec: 1.3
ruby-debug-base: 0.10.3
ruby-debug-ide: 0.4.10


Updated two gems:

ruby-debug-base [ruby-debug-base(0.10.5.jb2)]
ruby-debug-ide [ruby-debug-ide(0.4.15)]

Still no improvements.


Issue solved with RubyMine 3 final release.


I have 3.0 ga release and am getting this same popup.
When I try to update the gems the error message that does not appear to be a repository for ruby-debug-ide-0.4.15 and for ruby-debug-base-0.10.5.jb2-x86-mswin32.   However it says base installed successfully.



Please sign in to leave a comment.